Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎04-08-2017
Accepted Solution

Canon EOS 10D

Auto focus won't lock only shoots in manual or bright light in auto. New battery and CF card. No image on display dark screen with only the picture info (shot#,exposure ) playback says no image. IMG_2083.JPG

Highlighted
Esteemed Contributor
Posts: 2,362
Registered: ‎11-14-2012

Re: Canon EOS 10D

Have you tried a "hard reset"? you remove the battery & the clock battery (which I assume it had from my 20D ownership) & leave them out overnight to kill any built in memory problems. Any & all settings will be errased by this procedure.

"A skill is developed through constant practice with a passion to improve, not bought."
Highlighted
New Contributor
Posts: 3
Registered: ‎04-08-2017

Re: Canon EOS 10D

I'll try it thanks! Leave the CF card in or take that out too?

Highlighted
Esteemed Contributor
Posts: 2,362
Registered: ‎11-14-2012

Re: Canon EOS 10D

I don't think it matters but might as well remove it.

"A skill is developed through constant practice with a passion to improve, not bought."
Highlighted
VIP
Posts: 12,265
Registered: ‎12-07-2012

Re: Canon EOS 10D

[ Edited ]

I would certainly try the hard reset but when that doesn't work, I believe your ole 10D has given up the ghost. Not a candidate for repair either.

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
New Contributor
Posts: 1
Registered: ‎04-09-2017

Canon 5D Mark 1 - HELP

Hi Guys,

 

Sorry new to page and need help...

My camera was working just fine... now its not.

I use my camera on M all the time and I took one photo and now the screen is just black when I look through to take a picture I can't see anything except blackness...

I took the lens off and this fixed it for one photo then the same issue again, Im guessing its got something todo with the shutter?

How serious is this? what do I do? I have a newborn photo shoot in 4 days eeek

Highlighted
New Contributor
Posts: 3
Registered: ‎04-08-2017

Re: Canon EOS 10D

Hard reset no luck. Ghost is gone.....

Highlighted
Honored Contributor
Posts: 5,298
Registered: ‎06-25-2014

Re: Canon 5D Mark 1 - HELP


@kylie wrote:

Hi Guys,

 

Sorry new to page and need help...

My camera was working just fine... now its not.

I use my camera on M all the time and I took one photo and now the screen is just black when I look through to take a picture I can't see anything except blackness...

I took the lens off and this fixed it for one photo then the same issue again, Im guessing its got something todo with the shutter?

How serious is this? what do I do? I have a newborn photo shoot in 4 days eeek


If you can't see through the viewfinder, it's more likely the mirror than the shutter. Make sure the mirror isn't in the "locked up" position. Start by restoring the camera to factory settings.

 

If you take on photo shoots where other people depend on you, even if you don't charge for them, you're a borderline semi-professional. And a photographer in that situation requires a spare camera.

Bob
Philadelphia, Pennsylvania USA
Highlighted
VIP
Posts: 12,265
Registered: ‎12-07-2012

Re: Canon 5D Mark 1 - HELP

[ Edited ]

kylie,

Did you read this post above?

 

"Have you tried a "hard reset"? you remove the (main) battery & the clock battery ... & leave them out overnight to kill any built in memory problems. Any & all settings will be errased by this procedure."

 

I am assuming you also have a 10D?  Because this was a thread posted about a 10D not a more current model?

EOS 1DX and 1D Mk IV and several lenses!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement