Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎07-01-2017

Canon 80D WiFi Malfunction - No Access-Point network found and general malfunction.

Hi, 

I've recently bought a Canon 80D (W). Everyting but WiFi conection is working perfectly. 

 

Here is a walkthrough of what have I done:

 

All my conection attemps have been trying to link the camera to an iPhone 6.

- I downloaded Cannon Connect app

- Following the manual's instructions I tried to connect through Easy-Conection and my phone wouldn't find the wifi source. I even tried with an iPhone 5s, iPhone 5 ES and iPad and none of them could find the network. 

- I tried conecting the camera to my house-network and when finding networks the camera got freezed in that screen. (busy .. finding networks) or something like that. After a while, with no response in the touch screen, menu botton and others, I forced the camera to go Off with the On-Off switch, and the camera stayed frozen in the "busy ... " screen until I removed the battery. 

- I attempted again connecting to my house-network and it froze again. 

- I attempted conecting my camera as an access-point manualy and no devices could find the network that the camera should have been providing. 

- Through all the process I felt that the software was struggling with the wifi, having frozen screens and lag at times. 

 

So what I can add up is that either my WiFi sistem is damaged phisically, or that the software is damaged. I have thought on re-loading the software (I suppose you can do that through the Firmware Version update option). My version es 1.0.1. 

 

 

If there are any suggestions I would highly appreciate it. My to-do list is trying to update the firmware version and if nothing happens take it to a Canon service.

 

Thanks, 

 

Sebastian

Product Expert
Product Expert
Posts: 824
Registered: ‎10-17-2012

Re: Canon 80D WiFi Malfunction - No Access-Point network found and general malfunction.

Hello sebastianzisis

 

It's possible that updating your cameras firmware to the latest version will correct this issue.  

If the issue persists then you may wish to utilize the Canon web site to set up service.  


https://www.usa.canon.com/internet/portal/us/home/support/service-repair

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement