Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎12-01-2016

Canon 70D w/ external mic - No sound playback on camera

[ Edited ]

Hello,

 

I have a Canon 70D. I'm using it with an Audio Technica AT897 mic (with an XLR adapter). For some reason, when I play back recorded footage on the camera, there is no sound except for some very light static. However, when I put the footage on my computer and play it back there, the sound is perfectly fine.

 

I tried unplugging the mic and recording video with the built in microphone on the camera, and it played back fine. While this isn't a massive issue, it still would be nice to know if there is a fix. That way I will know if and when my external mic needs a replacement battery.

 

I know it isn't because my volume is turned down...

 

Has anyone else run into these sort of issues?

Highlighted
VIP
Posts: 9,670
Registered: ‎08-13-2015

Re: Canon 70D w/ external mic - No sound playback on camera

What happens if you record with the external microphone, and play it back with the external microphone unplugged?

 

If you suspect a battery problem, why don't you change it?

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Highlighted
Occasional Contributor
Posts: 8
Registered: ‎09-09-2018

Re: Canon 70D w/ external mic - No sound playback on camera

[ Edited ]

Hello all,

Rather than start a new thread I thought I'd try reviving this one as it seems to be the same problem.

I am brand new to this and also have a EOS 70D.

 

recorded without mic - playback fine

 

plugged in my external lavalier mic - playback no sound

 

No settings changed inbetween recordings.

 

The mic is: Premium 196" Dual-head Lavalier Microphone, Professional Lapel Clip-on Omnidirectional Condenser Mic [link disabled due to forum guidelines]

 

Any advice?

Highlighted
Product Expert
Product Expert
Posts: 1,076
Registered: ‎10-17-2012

Re: Canon 70D w/ external mic - No sound playback on camera

[ Edited ]

Mandi, 

We're sorry to hear that the issue persists.  We recommend attempting to try a different microphone with the camera. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Highlighted
Occasional Contributor
Posts: 8
Registered: ‎09-09-2018

Re: Canon 70D w/ external mic - No sound playback on camera

The mic is regularly used with other devices - PC & phone - with no trouble.

 

Also, looked at the manual and it talks about a wind canceling option and shows the audio screen... mine doesn't have any of that.  It is only showing audio on/off.  Could there be a FW issue?

Highlighted
Product Expert
Product Expert
Posts: 1,076
Registered: ‎10-17-2012

Re: Canon 70D w/ external mic - No sound playback on camera

Mandi, 

The latest version of the firmware is 1.1.3 so please ensure your camera is up to date. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Highlighted
Occasional Contributor
Posts: 8
Registered: ‎09-09-2018

Re: Canon 70D w/ external mic - No sound playback on camera

None of my screens look like the manual shows.

 

Looking to find the FW version on SETUP screen 4 (according to the manual, that's where it should be).  Only "sensor cleaning" and "battery Info" are listed. 

Highlighted
Product Expert
Product Expert
Posts: 1,076
Registered: ‎10-17-2012

Re: Canon 70D w/ external mic - No sound playback on camera

Mandi, 

The reason may be due to the mode you are in.  If you're not in a Program much such as P, Av, Tv or M then you will not see the comprehensive displayed only in those modes.  The automatic or Basic zone modes do not have the same set of options.  

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Highlighted
Occasional Contributor
Posts: 8
Registered: ‎09-09-2018

Re: Canon 70D w/ external mic - No sound playback on camera

Yeah, after digging more I found that.  I placed it in P mode, reset settings (just in case), then updated FW.

 

still no sound with ext mic, only without. 

Highlighted
Esteemed Contributor
Posts: 3,963
Registered: ‎02-17-2016

Re: Canon 70D w/ external mic - No sound playback on camera

Does your mic need phantom power?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement