Canon Community Canon Community
 


Reply
Frequent Contributor
Posts: 39
Registered: ‎07-04-2018

Canon 5D Mark III Back Focus Button Sticking

Canon 5D Mark III back focus button is starting to stick inside the body and not pop out. This is starting to happen on 2 of my cameras. Im not putting blame on Canon for this as they've both been used a lot and it's time to fix the problem before I have a major malfunction. :-)

I've cleaned the buttons up the best I could, but I think it's time to disassemble and clean them or figure out what's making them stick and not pop out nice and smooth. 

Anyone have this or deal with this problem before? I was looking online at disassembly videos and it doesn't look terrible difficult to get at the button.

Thanks for any advice!



Has anyone come across this problem? 

Product Expert
Posts: 144
Registered: ‎07-03-2019

Re: Canon 5D Mark III Back Focus Button Sticking

Hi llehmann,

 

Thanks for checking in with us.

 

As you might imagine, we aren't able to provide support on disassembling the camera since that could lead to more damage to the equipment or to personal injury, in certain limited cases.

 

If you decide to get the camera serviced, I would suggest that you email us to get the latest repair details for your area:

eosdigitalsupport@cits.canon.com

Frequent Contributor
Posts: 39
Registered: ‎07-04-2018

Re: Canon 5D Mark III Back Focus Button Sticking

OK... just to keep everything "fair"... I've been told that my 24-70 F2.8 II lens that broke on Dec 1, 2020 does not have a faulty ribbon cable. 
All tho the symptoms are exactly the same. The lens will only shoot on F2.8. Otherwise it will give you an Err 01.

So, stay tuned on to why if failed this time?!?!

Frequent Contributor
Posts: 39
Registered: ‎07-04-2018

Re: Canon 5D Mark III Back Focus Button Sticking

Now... in the spirt of "fairness"... another one of my lenes displayed the symptoms of the dreaded broken flex cable at a wedding this week (first week in Jan 2021). Yes, one of my stable of 24-70 F2.8 II lenes that I have. Not that we are keeping track... but my guess is this is the #8 repair for this reason. We will see if its the ribbon cable again or something else. 

 

Again... will fire at F2.8 otherwise you get an Err 01 on the camera. 


Now, lets talk a little bit about my backup lens. The tank that drives in reverse! (Referring to the telescopic focus being backwards). My 24-70 F2.8 version 1... regular flavor. I've had it for so many years and put it into retirement when the new II version came out. Used mainly as my backup lens. It's always been there for me. Never failed. Never had these issues. Just saying!

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement