Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎11-14-2020

Canon 40D Autofocus Will Not Work

Hello there,

 

I have a 40D with the kit USM lenses that the autofocus stopped working completely.

The camera takes pictures fine with manual focus, but I'm trying to fix this issue so I can use it as it was intended.

Firmware version is 1.0.8

 

Some things I have tried to fix this issue

  • Reset to Factory Settings
  • Removed/Replaced the CR2016 coin battery
  • Used a bulb on the AF sensor area to clear any potential dust
  • Cleaned the contacts for the lenses and the camera

All to no avail.

 

I bought this camera new back in the day and have babied it and taken great care of it over the years.

 

The interesting thing is that a friend recently gave me a Canon Rebel XSI that is having the exact same issue.

 

Am I dealing with some sort of planned obsolecense here?

 

Thoughts and suggestions would be greatly appreciated.

Highlighted
VIP
Posts: 10,710
Registered: ‎08-13-2015

Re: Canon 40D Autofocus Will Not Work

What if you have one bad lens, instead of two bad cameras?  BTW, make sure the AF/MF lens switch is on AF.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎11-14-2020

Re: Canon 40D Autofocus Will Not Work

I should have mentioned...

I have 2 kit lenses for each camera and I bought the 40D new in 2007 and have been very careful with both camera body and lenses over the years so I know they have been taken well care of.

 

I've tried all 4 of the lenses on both camera bodies and they all behave the same way (yes, AF is selected), so I am thinking this is a camera body issue, not a lens issue.

 

The camera tries to autofocus but won't take the pic, and the best way I can describe it is that it "stutters" back and forth trying to find focus but just can't get it. I have tried selecting/using the various focal points in the viewfinder, to no avail.

Highlighted
Reputable Contributor
Posts: 868
Registered: ‎12-24-2013

Re: Canon 40D Autofocus Will Not Work


@Greeblen wrote:

Hello there,

 

I have a 40D with the kit USM lenses that the autofocus stopped working completely.

 

The interesting thing is that a friend recently gave me a Canon Rebel XSI that is having the exact same issue.

 

Thoughts and suggestions would be greatly appreciated.


Please confirm....   Are you saying you have 2 cameras and 1 lens, and that both cameras will not AF with that 1 lens? 

Mike Sowsun
S110, SL1, 80D, 5D Mk III
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎11-14-2020

Re: Canon 40D Autofocus Will Not Work

[ Edited ]

As mentioned in a previous reply, I have 2 cameras and 4 lenses.

AF will not work properly on either camera body (40D and Rebel XSI) with any of the 4 lenses. 

All 4 lenses will AF perfectly and perform normally when used on another camera body that is not experiencing this AF problem.

Highlighted
Reputable Contributor
Posts: 997
Registered: ‎11-14-2012

Re: Canon 40D Autofocus Will Not Work

You can try if AF works when using a remote switch.
DCS 3c, DCS 520, D30, D60, 1Ds, 300D, 30D, 1000D IR, 7D, 6D, 6D, M5
15-45/3.5-6.3 IS, 16-35/4 IS, 22/2, 24/1.4 II, 24-105/4 IS, 50/1.4, 50/1.2, 85/1.8, 100/2.8, 70-200/2.8 IS II, 300/2.8 IS
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement