Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 9
Registered: ‎04-08-2021

Camera functions not responding fixed

My EOS R5 lost several functions today including loss of all menus for camera settings and playback, loss of mode functions, loss of auto focus, loss of metering, no shutter operation. I was able to take pictures in manual focus mode but could not review them in camera. Contacted support on the phone but because I could not access any menus, we could not reset camera or update firmware. Attempted to reset camera by removing battery, turning on camera and pressing shutter button several times. Also, connecting to computer and using EOS utility showed the camera was "busy." Phone support prognosis was to send camera in for repair.

 

After leaving camera for several hours with no battery, I was able to change the mode and updated firmware using EOS Utility (Mode previously stuck in Tv and could not be changed). Now all camera functions have returned to normal.

 

NOTE: I had just installed a new SD card 64 GB, 150 MB/s before this problem occured. New firmware 1.3.0 is supposed to fix cameras not operating properly with certain SD cards. It's interesting that the camera continued acting poorly even when I removed the card when I was troubleshooting. In any event, I have posted this for information purposes only. The camera is now functioning normally after setting for several hrs and updating firmware.

Reputable Contributor
Posts: 725
Registered: ‎02-13-2016

Re: Camera functions not responding fixed

Exactly what brand and model of caed are you using? Did you format the card in the camera? Is it a full size SD card or a micro SD card with an adapter? Did you buy the card at a local, reputable dealer (Best Buy for instance) or from Amazon or Ebay? There are some real problems with counterfeit memory cards sold by online dealers.

Occasional Contributor
Posts: 9
Registered: ‎04-08-2021

Re: Camera functions not responding fixed

[ Edited ]

So I misread the details on 1.3.0 firmware. The issue apparently is with CF cards, not SD cards.

 

"

9. Fixes a phenomenon, in which, in rare instances, the camera does not function normally when using certain CFexpress cards."

The card I installed is a SanDisk Extreme 64GB purchased from Amazon vendor, Digital Media Source. Selling price was $15. 35. B&H selling them for $15.49 so competitively priced. I have to clarify now that the card had been in the camera for a while since the purchase date was 3/15/21 and has most likely been causing no issues. The card was formatted in the camera. I bought 4 cards and have 2 in a Fujifilm and one in a Leica. No issues with either of those cameras.

 

So this adds to the mystery of why the camera went bananas. It has been working fine since the update.

 

Could it have been a lens issue? Tried an EF lens with Canon adapter. No change.

Could the camera have gotten wet? I had been out in misty weather but the camera never got wet or rained on.

Occasional Contributor
Posts: 9
Registered: ‎04-08-2021

Re: Camera functions not responding fixed

Checked card and is legit.

VIP
Posts: 11,985
Registered: ‎08-13-2015

Re: Camera functions not responding fixed


@unclejace54 wrote:

 

"Attempted to reset camera by removing battery, turning on camera and pressing shutter button several times. "

.


Sounds like your camera may be in need of service.  What happens when you turn it on without any memory cards?

 

When you attempt that type of reset, be sure to close the battery compartment door after removing the battery.  Might as well remove the memory card(s), too.  Turn on the camera switch.  Now, fully press and hold the shutter for at least 10 seconds.

 

 

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Occasional Contributor
Posts: 9
Registered: ‎04-08-2021

Re: Camera functions not responding fixed

A more thorough test test of the card reveals a 64Gb with actual size of 59GB and write speeds of 64MB/s, read speeds around 56 MB/s. Card says max read speed of 150 GB. Used an app along the lines of what F3 does on Mac's called sdspeed.  Having never done this depth of checking before, I have no idea what these numbers reveal about the card's authenticity and whether or not these results would cause or contribute to the issues I had with the camera.

Reputable Contributor
Posts: 725
Registered: ‎02-13-2016

Re: Camera functions not responding fixed

[ Edited ]

SD cards aren't always what they appear to be.

 

Member Ray-uk found this one about a year ago.

 

https://community.usa.canon.com/t5/General-Camera-Discussion/SD-Card-surprise/m-p/298835#M8518

 

This sort of thing seems to be exlusively an issue with certain eBay or Amazon vendors. Though I doubt you'd get a card like this from B+H Photo.

VIP
Posts: 11,985
Registered: ‎08-13-2015

Re: Camera functions not responding fixed


@unclejace54 wrote:

A more thorough test test of the card reveals a 64Gb with actual size of 59GB and write speeds of 64MB/s, read speeds around 56 MB/s. Card says max read speed of 150 GB. Used an app along the lines of what F3 does on Mac's called sdspeed.  Having never done this depth of checking before, I have no idea what these numbers reveal about the card's authenticity and whether or not these results would cause or contribute to the issues I had with the camera.


You may have uncovered nothing of any significance.  The "actual size" is easily explained.  Some of the storage space is used as a directory, ot keep track of where stuff is stored.

 

When you performed the speed testing, did you use a device that was capable of 150 GB read speed?

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Occasional Contributor
Posts: 9
Registered: ‎04-08-2021

Re: Camera functions not responding fixed

Kind of what I thought. I got higher transfer rates with a different card reader. Don't think my SD cards are an issue.

VIP
Posts: 11,985
Registered: ‎08-13-2015

Re: Camera functions not responding fixed


@unclejace54 wrote:

Kind of what I thought. I got higher transfer rates with a different card reader. Don't think my SD cards are an issue.


You cannot rule them out, not just yet.  Did you try the tests I suggested yesterday afternoon, yet?  

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement