Canon Community Canon Community

Frequent Contributor
Posts: 75
Registered: ‎03-12-2019

Re: Camera Connect app not working with iPhone 11 Pro

I've had similar experience and those few times I've had a stable connection with my iPhone 5, 6S, or 11, the app seemed unresponsive.

Chris P. Bacon
F-1; AE-1; EOS 1V, 5D Mk IV, 6D, 6D Mk II, 7D, and 7D Mk II
Occasional Contributor
Posts: 11
Registered: ‎06-04-2019

Re: Camera Connect app not working with iPhone 11 Pro

I'm having the same problem with connectivity with my iPhone and T7i.  It had worked fine previously but I've probably connected 100 times so far and every time it either says the connection failed or just drops off.  


I've spent literally hours on the phone with Canon tech support without any resolution.


It ocurred to me to try connecting to a different phone so I did that with the same result - failed! I initially thought it had to be the camera and in fact a Canon rep said I should send it in for repairs. After reading so many posts that others have similar problems though I decided that it can't be the camera.  


I then tried connecting to my computer and it worked flawlessly so the Camera's wifi/bluetooth transmitter must be fine.


I don't know what version IOS you're running but I have 13.3 and I think that may have someting to do with it.  For now, using Canon Camera Connect is not possible.


If you figure it out please share it with me and I'll be sure to do the same!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement