Canon Community Canon Community

Posts: 11,538
Registered: ‎08-13-2015

Re: Area selection zones not working

@cpstephens wrote:

This is happening to me, M-Fn will not scroll / select the AF modes, i am stuck on single point? i reset everything as pointed in the thread and still no joy. i reset everything of this 5d3 to another one that does not have this problem . could it be a firmware issue, the problematic one is 1.2.3, its a used  5d3 with 43k actuations, 

Did you reset Custom Controls, too?  The M.Fn might be reprogrammed to another function.  A “Restore Factory Defaults” reset does not clear Custom Controls.  Custom Controls have their own separate reset function in the Custom Controls menu.


Did you check the settings on the “Lock” settings button?  I don’t think a “Restore Factory Defaults” resets that setting, either.  You can select which buttons are disabled, and which are not.

All told, there are at least 3 places in the menus that you need to visit to fully reset the camera.  You could also turn the top dial to Green [A] mode, which should disable most every custom programming setting.


"Doctor told me to get out and walk, so I bought a Canon."
New Contributor
Posts: 3
Registered: ‎10-20-2018

Re: Area selection zones not working

if you mean C! C2 C3 yes i cleared those. i managed to get AF selection using the wheel on top, M-Fn still not working, i negated all the lock settings. Custom controlsCFn2 M-Fn to FEL which is the same as my other 5D3

New Contributor
Posts: 3
Registered: ‎02-01-2019

Re: Area selection zones not working

[ Edited ]

@AndyShust wrote:

Hello everyone.


I bumped into this problem some days ago. Only resetting camera settings (not custom functions) helped. I thought it would be useful to write this here.


Still no cue why the AF selection stopped working. I suspect connecting my camera to an Android tablet with DSLR Controller app, which might have messed up or locked the ability to choose AF points.

Ok so I'm not going crazy, glad I found this thread. My ability to change to manual autofocus point has gone away too. And I suspected it may be related to connecting my camera to my tablet through DSLR Controller. Seems like I'm not the only one this has happened to. Hopefully resetting all settings fixes it for me too.

Quick edit - resetting the settings fixed it for me. It's too bad DSLR Controller may have caused this, because I love that app!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement