Canon Community Canon Community
 


Reply
New Contributor
Posts: 4
Registered: ‎08-15-2017

7D with incorrect Mode Dial readings

I recently updated the firmware on my 7D to 2.0.6, and discovered on a recent shoot that I had lost the ability to do anything in Manual.  Upon closer inspection, it now looks like I have lost the ability to select "Creative Auto", Aperature Priotrity, and Manual.  I do, however, now have dual instances of "Program", Shutter Priority, and Bulb, each occupying one of the missing modes' slots.  I have tried clearing the defaults via the menu, as well as trying to do the factory default by removing the internal clock battery.  Is there anyway to rollback the firmware?  Any other ideas?  Many thanks

Honored Contributor
Posts: 5,972
Registered: ‎11-13-2012

Re: 7D with incorrect Mode Dial readings

Try reinstalling firmware.

 

If that doesn't work give Canon a call at 1-800-OK-CANON.

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
New Contributor
Posts: 4
Registered: ‎08-15-2017

Re: 7D with incorrect Mode Dial readings

Thanks mate, unfortunately I have tried a few times with reinstalling the firmware, including fresh dowloads, with no joy.  I will certainly be giving Canon a call this morning, though not expecting much as I am long out of warranty.

Highlighted
Honored Contributor
Posts: 5,066
Registered: ‎06-25-2014

Re: 7D with incorrect Mode Dial readings


@satmike wrote:

Thanks mate, unfortunately I have tried a few times with reinstalling the firmware, including fresh dowloads, with no joy.  I will certainly be giving Canon a call this morning, though not expecting much as I am long out of warranty.


We've heard of cases where the label on the mode dial has gotten rotated (it's sometimes glued on rather weakly), so that the dial's various settings no longer say what they mean. You should probably try to rule that out before spending money on a repair.

Bob
Philadelphia, Pennsylvania USA
Valued Contributor
Posts: 385
Registered: ‎10-21-2016

Re: 7D with incorrect Mode Dial readings

If you can find an old version of the firmware you can re-install that but I would suggest the the new version you installed was corrupted. The best thing to try first is to get a fresh download of the new version and re-install that.

New Contributor
Posts: 4
Registered: ‎08-15-2017

Re: 7D with incorrect Mode Dial readings

Thanks, but the label is affixed firmly.  The current mode dial readings are as follows:

A---------->Auto

CA-------->Program

P---------->Program

TV-------->TV

AV-------->TV

M--------->Bulb

B--------->Bulb

New Contributor
Posts: 4
Registered: ‎08-15-2017

Re: 7D with incorrect Mode Dial readings

Thanks, though I have tried with multiple, fresh downloads
Respected Contributor
Posts: 1,119
Registered: ‎02-06-2013

Re: 7D with incorrect Mode Dial readings

It's probably just a coincidence that a firmware was done - I think your Mode Dial is broken.

================================================
Diverhank's photos on Flickr
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement