Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 9
Registered: ‎01-24-2020

7D mii auto focus seems to work fine closeup, but not with any distance

[ Edited ]

Relatively new 7D markii was working perfectly, then suddenly had issues with AF with no incident to cause damage.  Sent it in to Canon factory to repair. Supposedly repaired (contacts replaced???) but when it returned, the same issues remain. Frustrated and hoping that someone has some insight or ideas...

 

HIstory: (Have owned the camera/lenses for over a year, shooting several times a week, so have solid experience and strong sense of what level of focus to expect in various situations.)

 

Photographed basketball game with Canon 70-200 2.8 -- perfect focus

Photographed flowers with Lensbaby 85mm (manual focus) -- perfect focus

Photographed birds with Tamron 150-600 g2 and Canon 70-200 2.8 -- focus issues -- camera seemed to struggle with what to focus on, moving in and out but not settling. Images were not in focus. 

 

Sent to Canon factory. Honestly, conflicting messages as to what was wrong (one person saying something about calibration, another saying something about error codes, and another saying that the contacts would be replaced.)  Even when it was returned, I was billed over $300 with no explanation as to what was fixed. But I trusted them....because it was Canon factory.

 

Well, nothing was fixed.  The same issues remain.

Photographed macro objects with Canon 100mm 2.8 -- perfect focus

Photographed soap bubbles with Canon 100mm 2.8 -- perfect focus

Photographed birds with Tamron 150-600mm and Canon 70-200 2.8 -- extremely poor focus, even though the birds were perched.  Even when I focused on stationary objects with these two lenses the focus was poor.  The 70-200 especially should have been tack sharp, but was not. 

 

My settings for the birds were fine (ex. 1/400 @ 375mm; Av 6.3; ISO500)
Lenses were on a tripod except for the basketball game.

Image stabilization turned off.

 

The example image was taken with the settings above, the original posted first and then a crop to show that the focus is not sharp.

 

It really seems that the camera can focus fine up close but the focus issues occur when the subject is at a distance.  I would be grateful for any ideas or suggestions before I sadly send it back to the Canon hospital?   tamron-5143.jpgtamron-5143-crop.jpg

Below is an older image showing the focal quality I expect from this camera/lens combo.

B077-(w)-web.jpg

VIP
Posts: 11,117
Registered: ‎08-13-2015

Re: 7D mii auto focus seems to work fine closeup, but not with any distance

I have zero experience with either Tamron 150-600mm lens, just the Sigma 150-600mm C when it comes to the 7D2.

 

I have mentioned this "issue" in past posts, so I guess now might be a good time to bring it up again.  I have used the Sigma 150-600mm C with a T5, 80D, and a 7D2.  All of the APS-C bodies seemed to captaine soft images, while my full frame 6D, and now the 6D2 captured tack sharp images.

 

EOS 6D2017_10_221791.jpg

 

The above shot was cropped from the shot below.  Look at the big kid's eyes.

 

EOS 6D2017_10_221791-2.jpg

 

Shot with a 6D and the Sigma 150-600mm C from a monopod.  Trying to handhold the beast for two hours was out of the question.  I will leave that challenge to the "pros" out there.  All of the pro sports photographers I know use monopods with their big lenses when shooting football.

 

However, I should point out that the results with the T5 and 80D were prior to the release of the firmware upgrade to the AF algorithms, which seemed to change the lens into a completely different beast.  A definite improvement.  No more back focus at the short end, and front focus at the long end.  No more tug-of-war between the OS in the lens and tracking using AI Servo mode in the camera.  

 

I saw those improvements on the full frame sensor bodies, but not with the 7D2.  My experience with the Sigma 150-600 C says that the lens does not like APS-C bodies.  Maybe you are experiencing something similar with the Tamron.

 

 

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Occasional Contributor
Posts: 9
Registered: ‎01-24-2020

Re: 7D mii auto focus seems to work fine closeup, but not with any distance

Thanks for your quick response.

 

I have only ever shot with ASP-C and have very sharp images, as shown in the third chickadee picture on my post.  That is the focus detail that I expect and am used to. My frustration is that, right now, the camera is not performing up to the level I know that it is capable of. Though the camera is only a year old, I have used the lenses with another camera for years and know, from experience, that there is something wrong with it. 

VIP
Posts: 11,117
Registered: ‎08-13-2015

Re: 7D mii auto focus seems to work fine closeup, but not with any distance

Maybe you need to do an AFMA check with the lens.  The only YouTube video that I have seen that actually works is called the " DOT TUNE " method to AFMA adjustments.  It takes more of the subjective guess work out of picture than other strategies.

 

Be warned, though.   It is easier to make a bad set of adjustments than a good set.  Take lot of test shots, and come up with a working average.  If your test shots are all over the map, then it is most likely YOUR technique is at fault.

 

I test my super telephoto lens in an empty parking lot that has a gradual uphill grade.  I use the lines separating the parking spaces as ruler, as well as a strategically placed set of targets at my focus point. 

 

Be aware that ambient light can dramatically affect your AFMA adjustments.  Speaking of which, this reminds me of another point that I discovered with some body/lens combinations.  Using UV or CPL filters can cause softer focus.  Try some shots without any filters, just as a test.  I only use B+W Nano Clear filters on my big lenses.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Occasional Contributor
Posts: 9
Registered: ‎01-24-2020

Re: 7D mii auto focus seems to work fine closeup, but not with any distance

Thank you, Waddizle. I really appreciate your effort to help me out.

 

I think that if it were a micro-adjustment issue, the macro photos that I took with small depth of field would have been affected than those that I took with a wider depth of field.  The focus issues actually occur with the wider depth of field.  Also, it occured with two different lenses and the error in focus was much more than what I would call "micro."  

VIP
Posts: 11,117
Registered: ‎08-13-2015

Re: 7D mii auto focus seems to work fine closeup, but not with any distance


@Gzagt wrote:

Thank you, Waddizle. I really appreciate your effort to help me out.

 

I think that if it were a micro-adjustment issue, the macro photos that I took with small depth of field would have been affected than those that I took with a wider depth of field.  The focus issues actually occur with the wider depth of field.  Also, it occured with two different lenses and the error in focus was much more than what I would call "micro."  


Macro photos.  Did you use auto-focus?  If you are convinced that the problem is the camera, then send it to Canon to get it checked out and possibly repaired or adjusted.  BTW, I only shoot at f/8 with my 150-600mm.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Reputable Contributor
Posts: 577
Registered: ‎10-21-2016

Re: 7D mii auto focus seems to work fine closeup, but not with any distance

Are you using Single point spot AF?

I have found that can easily cause problems on distant subjects, switching to normal single point cured it.

Honored Contributor
Posts: 5,558
Registered: ‎06-25-2014

Re: 7D mii auto focus seems to work fine closeup, but not with any distance

It's a very long shot, but conceivably a weak battery could cause AF problems. Typically, when I leave a camera at a Canon shop, they don't take the battery. So any problem with my battery would go unnoticed. But I assume you've tried more than one battery.

Bob
Philadelphia, Pennsylvania USA
Occasional Contributor
Posts: 9
Registered: ‎01-24-2020

Re: 7D mii auto focus seems to work fine closeup, but not with any distance

Thanks Bob, for your suggestion.  I did change batteries and it did not make a difference.  But I appreciate the idea.

Occasional Contributor
Posts: 9
Registered: ‎01-24-2020

Re: 7D mii auto focus seems to work fine closeup, but not with any distance

When I took the macro photos with the Canon 100mm, after I received the lens back from Canon factory repair, I used AF.

I'm confident that the issue is with the camera. I will likely send it back to Canon for a second look; just hoped that someone on here might have a brilliant idea that would solve the problem before I did that.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement