Canon Community Canon Community

New Contributor
Posts: 3
Registered: ‎08-06-2018

7D Flash Not Firing - Err 50

Hi Everyone,


I'm new to the forum, hoping to leverage your expertise in helping me find a solution to a problem I'm having a Canon 7D. I recently replaced the shutter on this camera and being a newbie to camera repair, I did not discharge the flash capacitor before doing so. At one point during the repair, I accidentally touched the discharge point on the flash circuit board (CY3-1754-000) with my tweezers, which caused a spark. After assembling the whole camera, it wouldn't turn on and the battery icon would flash on the top screen.


I replaced the flash circuit board with a new one (including new capacitor which had to be soldered on). After this, all functions worked properly, but the flash would not engage. It would pop up, but wouldn't fire, and the camera would shoot off an Error 50 (Electric Control Malfunction). I replaced the flash assembly itself, but am still getting the same error.


Things I've done to troubleshoot since then:

- Reseat all the cables that I disassembled during repairs

- Measured capacitance on flash capacitor (270uF) as well as on the smaller one next to it (310 uF)

- Measured resistance between yellow connector pin and flash capactor (-), as well as red connector pin and flash capactior (+), both of which were around 0-2 Ohms, so there is a connection there.

- Measured voltage in flash capacitor right after trying to fire flash. Measured 0.5V

- Checked resistance between various IC pins and compared with previous damaged board. All values are more or less the same


Not really sure how to proceed further. Don't want to throw money into another new flash circuit board, especially if the issue isn't with it. Any help would be greatly appreciated. Thanks!

Reputable Contributor
Posts: 861
Registered: ‎10-12-2012

Re: 7D Flash Not Firing - Err 50

Hi, dimsh2000!


We just wanted to let you know that we don't recommend do-it-yourself repairs. It's best to let a professional Canon Factory Service Center Technician do the work to keep you and your gear safe.


To start your repair process, you can complete a Repair Request on our website.


Valued Contributor
Posts: 372
Registered: ‎10-21-2016

Re: 7D Flash Not Firing - Err 50

You need to measure the voltage across the main capacitor before attempting to fire the flash, when charged it should be around 250-300 V. If it isn't reaching this voltage then it must be a fault in the charging generator on the board.


As the previous post suggests you shouldn't play with this unless you know what you doing but according to what you have done already it sounds as though you are competent, just be careful, that 300 V hurts when it goes up your fingers.

New Contributor
Posts: 3
Registered: ‎08-06-2018

Re: 7D Flash Not Firing - Err 50

Any idea what the charging generator on a board like this looks like? Or the chip PN? I found a component LV8401, which a motor driver, but it seems to be working fine. There's also a 20AAJ IGBT for Strobe Flash which seems to be working fine as well.

New Contributor
Posts: 3
Registered: ‎08-06-2018

Re: 7D Flash Not Firing - Err 50

Found the root cause! The flash circuit board that was sent to me was faulty and was missing an oscillator. Without an oscillator, the flash won't fire. Going to open a case with the buyer and get a replacement. Thanks for all your help!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement