Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎05-25-2016
Accepted Solution

70D using Diffuser - Flash button press does nothing

I have used my diffuser on my old XSI for years and when I went to try it on my new 70D the camera Flash seems to disable. When this is install in the hotshoe and I try to press the flash button, nothing happens. Soon as I remove it the button works. 

 

Highlighted
Esteemed Contributor
Posts: 2,372
Registered: ‎11-14-2012

Re: 70D using Diffuser - Flash button press does nothing

Not sure I understand the situation but IF you install something into the hotshoe it presses down a switch to prevent the built in flash from popping up. If it tried to pop up there would be a problem because something SHOULD be in it's way.

"A skill is developed through constant practice with a passion to improve, not bought."
Highlighted
Esteemed Contributor
Posts: 4,190
Registered: ‎02-17-2016

Re: 70D using Diffuser - Flash button press does nothing

What is this thing called "Diffuser" is it something on the pop-up flash?  can you provide a link?

Highlighted
New Contributor
Posts: 3
Registered: ‎05-25-2016

Re: 70D using Diffuser - Flash button press does nothing

Highlighted
Esteemed Contributor
Posts: 4,190
Registered: ‎02-17-2016

Re: 70D using Diffuser - Flash button press does nothing

I think Cicopo is right, the camera thinks there is something that will block the pop-up flash and keeps it retracted. You might be able to figure out where the switch is and modify the diffuser to not hit it.

Highlighted
New Contributor
Posts: 3
Registered: ‎05-25-2016

Re: 70D using Diffuser - Flash button press does nothing

Thanks for your input. I'll give it a closer look at those contact points.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement