Canon Community Canon Community
 


Reply
New Contributor
Posts: 4
Registered: ‎06-03-2017

70D Stops recording video after a few seconds

Other people have had the same problem, but mine is a little different. My card is a PNY 64GB 90MB/Second Class 10 that I format after putting into camera. When I first got the camera a couple of years ago I could record as long as I wanted. Now, only a few seconds, so I don't get the video I want. Most of the others with this problem needed to step up to a faster card. This one exceeds all the specs that were mentioned.

 

Also, I can't find a setting in my Menu to set the "Automatic Shutoff". Does the 70D have that, and if so, how do I get to it?

 

Really appreciate any help I can get.

Esteemed Contributor
Posts: 4,952
Registered: ‎06-25-2014

Re: 70D Stops recording video after a few seconds


@loyd wrote:

Other people have had the same problem, but mine is a little different. My card is a PNY 64GB 90MB/Second Class 10 that I format after putting into camera. When I first got the camera a couple of years ago I could record as long as I wanted. Now, only a few seconds, so I don't get the video I want. Most of the others with this problem needed to step up to a faster card. This one exceeds all the specs that were mentioned.

 

Also, I can't find a setting in my Menu to set the "Automatic Shutoff". Does the 70D have that, and if so, how do I get to it?

 

Really appreciate any help I can get.


There are only two kinds of automatic shutoff, and I don't believe either of them is ever optional:

1)  The camera shuts off when it starts to overheat, to avoid risking damage to the sensor or vulnerable circuit elements.

2)  The camera stops recording after 30 minutes, to avoid being taxed as a video camera by the EU and other jurisdictions that adhere to the same definition.

Bob
Philadelphia, Pennsylvania USA
New Contributor
Posts: 4
Registered: ‎06-03-2017

Re: 70D Stops recording video after a few seconds

I was aware of that, but some posts have mentioned the Auto-shutoff setting. It still stops recording after a few seconds. Any idea what is causing that?
Moderator
Posts: 1,368
Registered: ‎10-25-2012

Re: 70D Stops recording video after a few seconds

Hi loyd!

 

Have you transferred everything off your card and done a low-level format in the camera, or tried a different card, just to make sure your card hasn't degraded or gotten electronically damaged somehow?

New Contributor
Posts: 4
Registered: ‎06-03-2017

Re: 70D Stops recording video after a few seconds

Yes, I did both. I low level formatted the original card and another card of the same type and the video still shuts off after a few seconds of filming. Any other ideas?
New Contributor
Posts: 4
Registered: ‎06-03-2017

Re: 70D Stops recording video after a few seconds

[ Edited ]

Just got the "ultimate" SD card - SanDisk Extreme Pro 64GB, 95MB/Sec class 10. I low level formatted it and video ran for 3 seconds before stopping. I hope someone can offer a suggestion as to what is going on and how I might be able to fix it.

New Contributor
Posts: 2
Registered: ‎05-22-2019

Re: 70D Stops recording video after a few seconds

Hi I realize that this is two years later however I haven't seen any correct advice for this issue. It is a settings issue. In the settings section the "video snapshot" icon has been selected which will only allow for 5 second shots to be put together. Deselect this option. Yay!

New Contributor
Posts: 1
Registered: ‎07-28-2019

Re: 70D Stops recording video after a few seconds

Want to thank you. Was driving me CRAZY!
New Contributor
Posts: 2
Registered: ‎05-22-2019

Re: 70D Stops recording video after a few seconds

[ Edited ]

You are welcome. Have the best day ever. [Mod Note: Link Removed Per Forum Guidelines

Peace

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement