Canon Community Canon Community
 


Reply
New Contributor
Posts: 4
Registered: ‎05-07-2019
Accepted Solution

5D will not set Custom White Balance

Is there some setting on the EOS cameras (besides being set on "Auto") that will prevent the Custom White Balance confirmation diaglog box from popping up once the image you want to use for the white balance has been selected? So that the image information isn't actually used to change the White Balance? 

 

Previously on my 5D the Custom White Balance function has worked, with the dialog box asking for confirmation that I want that image's white balance information imported popping up, requiring me to select "OK" or "Cancel". I would select "OK" and then I could see the camera processing the new information and then see that the WB had changed on the menu display.

 

But now, when I  get to the image I want to select,  if "Custom White Balance" is selected on the top of the camera, when I hit the "Select" button on the back of the camera, I get no pop up box, instead I am returned to the red menu, with the seelction highlighted again on "Custom White Balance". If I then select "Custom White Balance" again, it starts the process over again. I'm caught in a loop.

 

If "Auto White Balance" is selected on the top of the camera, and I try to set the Custom White Balance from the menu, I get an orange box prompting me to change the setting on the top of the camera to "Custom White Balance". Even if I do that and immediately go back to the Menu, I do not get the confirmation box once I select the target image.

 

The reason I think it could be a setting, or some kind of user error,  is that I tried setting the Custom White Balance on my old 20D, just to see what would happen and I'm experiencing the exact same issue.

 

The camera manual says to 1) capture the target image, 2) select Custom White Balance from the red menu, 3) Select the target image captured in step 1, 4) press "set", and 5) change the WB menu on the top of the camera to "Custom White Balance". If I try to follow this, the process fails at step 4, where I get the orange box telling me to change the WB menu to CWB. 

 

I have tried: Using the sequence outlined in the camera manual, using a different card, newly formatted card, removing card and battery and doing a hard reset of the camera by holding down shutter button for 20 sec, and  reinstalling the firmware. 

Product Expert
Product Expert
Posts: 841
Registered: ‎10-17-2012

Re: 5D will not set Custom White Balance

Hello can2family, 

 

When you select the image you wish to use for the CWB, you press the Set/ Select button on the back of the camera and like you said are returned to the menu.  This is where the process stops.  The CWB information is now set in the camera.  Any further going back into the CWB menu function, like you said, just starts the process over.  All you need to do from there is to press the <AF-WB> and use the multicontroller to select the Custom WB icon on the top LCD panel.  Shoot a few photos after you set the Custom WB and check to see if it is correct. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 4
Registered: ‎05-07-2019

Re: 5D will not set Custom White Balance

Thanks Tim for your reply! I understand what you are saying, but after I select the target image, press "Set" and it returns me directly to the red menu, the color temperature displayed just below "Custom White Balance" does not change. If the target image white balance settings are successfully imported, shouldn't that show the adjustment?
New Contributor
Posts: 4
Registered: ‎05-07-2019

Re: 5D will not set Custom White Balance

Also, before my original post, I had called Canon support and they had me do many of the actions to correct the problem. After none were successful, they told me that the camera was not working correctly and that they no longer support it.

But I question that now, because my 20D behaves the same way. I have been using the camera infrequently so am thinking it's me doing something wrong.

I have searched for video tutorials on setting CWB on the 5D Classic so I could see what is displayed on the LCD screen throughout the process and cannot find anything. I could have sworn that it was the same process as the Mark II, which I CAN find tutorials for - the Mark II and newer models have the confirmation dialog box where you must select "OK" before the target image white balance settings are applied to the camera.
Highlighted
Product Expert
Product Expert
Posts: 841
Registered: ‎10-17-2012

Re: 5D will not set Custom White Balance

Hello can2family, 

I have copied and pasted the Canon Knowledge Base article that covers the process step by step.  It is located on our web site, here, for your convenience.  The color temperature won't reflect a kelvin value on the screen, it will only ever show the Custom WB icon.  The EOS 20D and EOS 5D are more or less identical in this process, which is why it seems the same for both.  Whether you have it set correctly or not should show in the images, take a couple before and after shots.  

With custom white balance, you shoot a white object that will serve as the basis for the white balance setting. By selecting this image, you import its white balance data for the white balance setting.

 


1. Press the <AF WB> button. ()
2. Select the custom white balance.
  • Look at the LCD panel and turn the <> to select <>.
3. Photograph a white object.
  • The plain, white object should fill the partial metering circle.
  • Set the lens focus mode switch to <MF>, then focus manually.
  • Set any white balance setting.
  • Shoot the white object so that a standard expsoure is obtained.
4. Select [Custom WB].
  • Turn the <> dial to select [Custom WB], then press <>.
  • The custom white balance screen will appear.
5. Select the image.
  • Turn the <> dial to select the image captured in step 3, then press <>.
  • The image's white balance data will be imported and the menu will reappear.
  • If the exposure obtained in step 3 is underexposed or overexposed, a correct white balance might not be obtained.
  • If an image was captured while the processing parameter was set to [B/W], it cannot be selected in step 5.
  • Instead of a white object, an 18% gray card (commercially available) can produce a more accurate white balance.
Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 4
Registered: ‎05-07-2019

Re: 5D will not set Custom White Balance

Thanks again Tim for the information!

 

I was able to verify today that the process outlined in the manual does work, the CWB is set on the 5D Classic without the dialog window asking for confirmation, like the Mark II. I think my lighting scenarios were too similar for me to see the difference before. Today I compared two very different light sources and could clearly see the changes in the CWB. Thanks so much for responding!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement