Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎08-22-2018
Accepted Solution

5D Original not responding

[ Edited ]

 I've recentley picked up a Canon 5D original and found that the camera will sometimes refuse to take pictures. The camera knows it is on as the top view is live but it will refuse to show anything on the LCD. It will change the mode, ISO, AF drive, and shutter speed but that's about it. When the camera actualy works for the breif time I had it working, It will often crash requiring me to remove the battery or show the picture in a low bitrate like a 90s computer. I'm sure the lenses and the CF card isn't a problem as they work fine with my 7D Mk2. I'm starting to think it's the D-Board (Main system board) at falt

 

IMAG0757.jpg

 

(Edit) I was able to get the camera to take a picture and this is what I mean by it looks like a 90s computer

Right is the 5D, Left is the 7D mk2. Same image

IMAG0761.jpgIMAG0761.jpg

Valued Contributor
Posts: 368
Registered: ‎10-21-2016

Re: 5D Original not responding

As the camera works perfectly sometimes then I would think it is unlikely to be a board at fault. It is more likely to be a bad connection somewhere, modern cameras have a variety of plug in cable connections and as these get older the connecting surfaces can get tarnished and depending on temperature and or humidity they sometimes don't make a proper connection. Probably just a case of old age .... they don't make em like they used to !

 

If you are able then you could strip the camera down and clean the connectors yourself but if you have to pay someone else to do it then it probably wouldn't be economically viable.

VIP
Posts: 11,219
Registered: ‎12-07-2012

Re: 5D Original not responding

You tried the easy stuff?  I think your 5D is done.  I also don't think Canon still services it.  You can try Midwest Camera repair. They will fix it.

EOS 1DX and 1D Mk IV, even less and less other stuff.
Occasional Contributor
Posts: 19
Registered: ‎03-15-2018

Re: 5D Original not responding

I totally agree with Ray-uk's suggestion.

 

Check on a previous thread and have fun reading it. DIY or not ? Your choice.

 

 

 

 https://community.usa.canon.com/t5/EOS/Weird-polarized-view-on-older-Canon-DSLR-EOS-5D-DIY-sharing/t...

Occasional Contributor
Posts: 19
Registered: ‎03-15-2018

Re: 5D Original not responding

[ Edited ]

1. "refuse to show anything on the LCD"

 

5D has no liveview feature.

 

2 "show the picture in a low bitrate like a 90s computer"

 

LCD shows a polarized effect - check out the above link.

 

 

Try upload the pic to a computer to see if it is very bad as it shows on the camera lcd.

New Contributor
Posts: 2
Registered: ‎08-22-2018

Re: 5D Original not responding

I've contacted Adorama and I'm going to return the unit.

 

The polarizing thing from what you mentioned is half of the problem. The other half is that the camera will sometimes refuse to show anything like the menu or take a picture. I'm going to pick up a diffrent unit and hope it dosen't have the same problems

VIP
Posts: 11,219
Registered: ‎12-07-2012

Re: 5D Original not responding

"I've contacted Adorama and I'm going to return the unit."

 

Good, it was done. Adorama is good to work with.

EOS 1DX and 1D Mk IV, even less and less other stuff.
Occasional Contributor
Posts: 19
Registered: ‎03-15-2018

Re: 5D Original not responding

Good idea to get a replacement.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement