Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 14
Registered: ‎04-29-2013

5D Mk III external flash does not work in live view mode

I feel really dumb, but I don't get it. I shoot video so I usually have no use for a flash, but today Ineeded to take pictures and I couldn't get it to work. I figured out that it only works whenI'm not in live view. I read something in a forum about turning off some setting, but doing so didn't not fix it. Canon can't be that stupid, so it must be me.
Highlighted
VIP
Posts: 13,294
Registered: ‎12-07-2012

Re: 5D Mk III external flash does not work in live view mode

You didn't mention what flash you are trying to use?

Non-Canon flash units will not fire in Live View mode unless Silent Shooting is set to Disable. Check your camera and check that you've adjusted that setting accordingly.

 

The flash is mounted on the hotshoe?  Use Canon brand flashes!

EB
EOS 1DX and 1D Mk IV and several lenses!
Highlighted
Occasional Contributor
Posts: 14
Registered: ‎04-29-2013

Re: 5D Mk III external flash does not work in live view mode

Speedlite 270EX II. On hot shoe. Power switch set to On. I disabled Silent LV Shooting and Silent control. Steady red light on unit. Blinked at first. Replaced batteries. Tried various shooting modes
Highlighted
Respected Contributor
Posts: 1,076
Registered: ‎10-17-2012

Re: 5D Mk III external flash does not work in live view mode

Hello Percoplus,

When shooting with your Speedlite 270EX II and EOS 5D Mark III, you should be able to take pictures without issues.  So, when you are shooting using the viewfinder, this issue does not occur?  Is this correct?  Are you able to try a different flash on the camera to test this issue?  

We hope this helps answer your question, but if you would like to get in touch with our technical support team directly you can do so through our main web site.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Highlighted
Occasional Contributor
Posts: 14
Registered: ‎04-29-2013

Re: 5D Mk III external flash does not work in live view mode

Tim,

No, my question is not answered. The flash only works if I am NOT in live view.  I don't have another flash (or camera) to try. I read somewhere that the flash should work if I turned off something - like the silent shooting mode or something like that. It does not work. But I don't understand what the silent mode has to do with anything. So, maybe there is some other setting.

Highlighted
VIP
Posts: 13,294
Registered: ‎12-07-2012

Re: 5D Mk III external flash does not work in live view mode

Silent Mode shooting does not complete the cycle until you remove your finger from the shutter button.

But at this point you are going to have to get another flash to try.  It is more likely there is something wrong with the flash.

The camera is just a trigger.

EB
EOS 1DX and 1D Mk IV and several lenses!
Highlighted
Honored Contributor
Posts: 5,558
Registered: ‎06-25-2014

Re: 5D Mk III external flash does not work in live view mode

[ Edited ]

@ebiggs1 wrote:

Silent Mode shooting does not complete the cycle until you remove your finger from the shutter button.

But at this point you are going to have to get another flash to try.  It is more likely there is something wrong with the flash.

The camera is just a trigger.


If the camera is just a trigger, then how does the flash know whether you're in live view or not? By that reasoning, the problem, assuming the OP has stated the symptoms correctly, would have to be in the camera.

 

Since one wild speculation is as good as another, how about this: Presumably the camera triggers the flash by applying a voltage across a couple of contacts. Suppose the voltage the camera is producing is marginal for the purpose. Since live view places an additional power load on the camera, maybe that's enough to drop the voltage applied to the flash below the threshold value. Since the camera probably generates the voltage by charging a capacitor, the thought is that LV is preventing the capacitor from becoming fully charged.

Bob
Philadelphia, Pennsylvania USA
Highlighted
VIP
Posts: 13,294
Registered: ‎12-07-2012

Re: 5D Mk III external flash does not work in live view mode

"Since one wild speculation is as good as another, how about this ..."

 

A wise man you are, as this is just keyboard speculation since we can not touch or see his equipment.  As to the camera is just a trigger, it is just a trigger.  The other contacts are for ETTL functions.  If the flash was just a bulb the camera would fire it.

Maybe not quite that simple but almost.  I am still going with the flash has a problem.

EB
EOS 1DX and 1D Mk IV and several lenses!
Highlighted
Occasional Contributor
Posts: 14
Registered: ‎04-29-2013

Re: 5D Mk III external flash does not work in live view mode

Well, I guess I have a good excuse to visit Fry's today! They sold me the camera

Highlighted
New Contributor
Posts: 1
Registered: ‎11-30-2015

Re: 5D Mk III external flash does not work in live view mode

I am also having issues with external flash on my Canon 5D Mk III. Not certain of this is 100% related to Live View.

 

Specifically, I am triggering 3X Profoto B1 Off-Camera Flash using a Profoto Air Remote TTL-C radio trigger.

 

I've been shooting with these flashes for over a year without problems, but within the past two weeks flash triggering has become hit or miss -- meaning I can't work, because nobody shooting with an $8,000 strobe package is in the game for hit or miss results.

 

Either I've messed up some obscure setting in the 5D Mk III menus, or else I've gat an intermittent hardware failure in progress in either the camera or the Air Remote.

 

BTW - The test button on the Air Remote is 100% reliable in triggering the flashes.

 

Besides the Profoto Air Remote TTL-C, I also have a standard (non-TTL) Profoto Air Remote. Which gives me an additional testing option, but also additional uncertainty since the non-TTL remote does not communicate with the camera using all the TTL contacts.

 

Firmware in all B1 flash heads and the Air Remote TTL-C were updated to latest release as of yesterday, November 29, 2015, with no change in reliability.

 

Really got rattled yesterday, with too many variables here to isolate any one thing and identify the problem. This thread never seemed to receive a definitive solution. I would appreciate an official response from Canon addressing every menu setting that impacts external flash triggering on the 5d Mk III. It seems I need to look at software and configuration first before I send my camera in for inspection.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement