Canon Community Canon Community
 


Reply
Highlighted
Honored Contributor
Posts: 5,310
Registered: ‎06-25-2014

Re: 5D Mk III external flash does not work in live view mode


@dannygrizzle wrote:

I am also having issues with external flash on my Canon 5D Mk III. Not certain of this is 100% related to Live View.

 

Specifically, I am triggering 3X Profoto B1 Off-Camera Flash using a Profoto Air Remote TTL-C radio trigger.

 

I've been shooting with these flashes for over a year without problems, but within the past two weeks flash triggering has become hit or miss -- meaning I can't work, because nobody shooting with an $8,000 strobe package is in the game for hit or miss results.

 

Either I've messed up some obscure setting in the 5D Mk III menus, or else I've gat an intermittent hardware failure in progress in either the camera or the Air Remote.

 

BTW - The test button on the Air Remote is 100% reliable in triggering the flashes.

 

Besides the Profoto Air Remote TTL-C, I also have a standard (non-TTL) Profoto Air Remote. Which gives me an additional testing option, but also additional uncertainty since the non-TTL remote does not communicate with the camera using all the TTL contacts.

 

Firmware in all B1 flash heads and the Air Remote TTL-C were updated to latest release as of yesterday, November 29, 2015, with no change in reliability.

 

Really got rattled yesterday, with too many variables here to isolate any one thing and identify the problem. This thread never seemed to receive a definitive solution. I would appreciate an official response from Canon addressing every menu setting that impacts external flash triggering on the 5d Mk III. It seems I need to look at software and configuration first before I send my camera in for inspection.


Given your comments on the seriousness of the situation, I don't understand why you still don't know whether the problem is with the camera or the remote trigger. Anyone who uses $8000 worth of flash equipment surely has access to a spare camera (and probably also a spare trigger) and can swap the components around and discover what works and what doesn't. If, under that testing, nothing works reliably, then one might suspect a problem in the strobe assembly itself.

Bob
Philadelphia, Pennsylvania USA
Highlighted
New Contributor
Posts: 1
Registered: ‎04-25-2016

Re: 5D Mk III external flash does not work in live view mode

@dannygrizzle:

I got the same problems and found no way to solve the problem. I just switch off the remote, change to live view mode, back, and start the remote again - awful, but I did not find another way.

Be happy not to work with the EOS 5Ds - this combination doesn't work anyway. I had so much trouble during my shootings, that I went back to use the 5Dmk3 when I need flash support with Profoto B1 flashes. The EOS 5Ds seems to fail in synchronisation with the B1s, I tried hard between 1/15 and 1/100, but camera exposure is not synchronous with flash firing ... That's high tech progress and innovation, sometimes I am getting crazy with these problems!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement