Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎03-29-2018

Re: 5D Mark iii problem with live view: no image is recorded when I take a shot

Today, I went to shoot sun rise photos.  I shot in both live view and normal shooting.  I coud see all my images until I finished shooting.  Before I left, I checked all the images taken during this morning, it was fine for a while and then suddenly, the screen had an error message that this image can't be displayed.  I thought the photo was corrupted and so delete it. 

 

The next photo displayed was the photo which I took yesterday.  When I checked further, all the photos taken this morning were not there.  I thought perhaps I could extract the photos via the computer after I returned home.

 

After I arrived home and tried to export the photos to my computer.  I found that none of the photos taken this morning were recorded on the card.

 

This is totally shocking to me.  Could someone pls advise me what happened and how to avoid this problem to recur again.

Honored Contributor
Posts: 5,558
Registered: ‎06-25-2014

Re: 5D Mark iii problem with live view: no image is recorded when I take a shot


@Akkw2800wrote:

Today, I went to shoot sun rise photos.  I shot in both live view and normal shooting.  I coud see all my images until I finished shooting.  Before I left, I checked all the images taken during this morning, it was fine for a while and then suddenly, the screen had an error message that this image can't be displayed.  I thought the photo was corrupted and so delete it. 

 

The next photo displayed was the photo which I took yesterday.  When I checked further, all the photos taken this morning were not there.  I thought perhaps I could extract the photos via the computer after I returned home.

 

After I arrived home and tried to export the photos to my computer.  I found that none of the photos taken this morning were recorded on the card.

 

This is totally shocking to me.  Could someone pls advise me what happened and how to avoid this problem to recur again.


Did you have cards in both slots? One of the annoying characteristics of Canon's dual-slot cameras is that if you take out the card that's in use, the camera will permanently switch to the other slot. I.e., it won't automatically switch back to the original slot when you put the card back in. It can make you think you've lost shots, when they're actually on the other card.

Bob
Philadelphia, Pennsylvania USA
New Contributor
Posts: 3
Registered: ‎03-29-2018

Re: 5D Mark iii problem with live view: no image is recorded when I take a shot

Bob, thanks for response. I have dual cards, and both were in their correct respective slot. I could initially see most of the photos taken this morning and was happy with the effect of the sunrise. Then all of a sudden. The can't display image message appeared. I thought I just deleted that image, but in fact all the photos taken this morning got deleted.
I checked both cards at home and there were 200 images missing. New photos which I took at home to check my camera had serial number 200 spaces gone forward.
I re-formated both my cards today.
Tomorrow I will go to shoot sunrise again. I set my camera to use the CF card instead. Keep my fingers crossed and hope to get some good photos.
As a precaution, I took another Canon 7D camera just in case this 5D non recording problem persisted. Keep my fingers crossed now.

Honored Contributor
Posts: 5,558
Registered: ‎06-25-2014

Re: 5D Mark iii problem with live view: no image is recorded when I take a shot


@Akkw2800wrote:
Bob, thanks for response. I have dual cards, and both were in their correct respective slot. I could initially see most of the photos taken this morning and was happy with the effect of the sunrise. Then all of a sudden. The can't display image message appeared. I thought I just deleted that image, but in fact all the photos taken this morning got deleted.
I checked both cards at home and there were 200 images missing. New photos which I took at home to check my camera had serial number 200 spaces gone forward.
I re-formated both my cards today.
Tomorrow I will go to shoot sunrise again. I set my camera to use the CF card instead. Keep my fingers crossed and hope to get some good photos.
As a precaution, I took another Canon 7D camera just in case this 5D non recording problem persisted. Keep my fingers crossed now.


How big were the cards? We had a report a few days ago from a user who had photos unaccountably vanish from his camera. He was using a 128GB card, which is quite large. Conceivably some cameras have a problem keeping up with the data on very large cards.

Bob
Philadelphia, Pennsylvania USA
New Contributor
Posts: 3
Registered: ‎03-29-2018

Re: 5D Mark iii problem with live view: no image is recorded when I take a shot

Hi, Bob,

 

Thanks for yr response.  My CF card and SD card are both small, 32GB only.  A friend who is expert with camera advised me to buy cards with smaller memory to avoid the problem which you mentioned above.

 

Still my camera didn't record the images properly on to the card.

 

The only mystery to me up to now was I had been checking the photos taken regularly and the photo serial number kept advancing.  Before I went home, I made a final check and showed the good shots to my friends and then the error message came up and after the deletion of one image, the rest disappeared. Very very sad.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement