Canon Community Canon Community
 


Reply
New Contributor
Posts: 4
Registered: ‎06-16-2018

5D Mark iii back lcd not working other than auto mode

I have a 5D mark iii which I have been using for last 5 years. It was working absolutely fine. But today morning I found that the back of the lcd is not displaying anything other than fully auto mode. I can take pictures in manual mode and review them in auto but it is difficult.
None of the button like Quick view, or Menu or Image playback is displaying anything in manual mode but working absolutely fine in auto mode.
Product Expert
Posts: 74
Registered: ‎05-22-2018

Re: 5D Mark iii back lcd not working other than auto mode

Hi soumenchatz,

 

Welcome to the Canon Forum!

 

It is unusual that the LCD screen is not able to display any information at all when not in Auto mode. I would go to the Setup (yellow wrench) menu section of the camera and reset the settings to default. If this behaviour continues after resetting the camera I would contact our Technical Support team for further assistance.

 

Please CLICK HERE to reach our friendly Technical Support Team by phone or email.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

New Contributor
Posts: 4
Registered: ‎06-16-2018

Re: 5D Mark iii back lcd not working other than auto mode

There is no reset option in Auto mode. Also I have reached out to technical support but they have no idea how to resolve it.
Product Expert
Posts: 74
Registered: ‎05-22-2018

Re: 5D Mark iii back lcd not working other than auto mode

[ Edited ]

Hi soumenchatz,

 

One other thing to try would be to remove everything from the camera except a Canon battery pack (memory card, lens, etc...) and see how it behaves. If the display still only shows information in the Auto mode the camera body would need to be sent in for a service evaluation.

 

A repair request can be started online HERE.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

New Contributor
Posts: 4
Registered: ‎07-14-2019

Re: 5D Mark iii back lcd not working other than auto mode

Hi

I saw your post from 2018, but today I started to face the same problem.

Could you tell me what was the final solution you got .

Thank you in advance

Luis Correia

 

New Contributor
Posts: 4
Registered: ‎06-16-2018

Re: 5D Mark iii back lcd not working other than auto mode

I had to send it to Canon for repair. They did not tell me the root cause of the problem but it appears certain electronic malfunction which blocks the manual mode to not work. Btw, is your live view working in manual mode? Also check menu options are coming or not, if either of them are working a factory reset may solve the problem
New Contributor
Posts: 4
Registered: ‎07-14-2019

Re: 5D Mark iii back lcd not working other than auto mode

Thank you
The live view is not working as well
The menu only shows the A mode options and because of that I cannot reset to factory default
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement