Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎04-05-2016

5 D III power off issues.

I just received my 2nd 5D III from Adorama, an open box purchase, which interestingly has the same exact issue as the one I returned.  I have power off set  for 2 min which it does.  But no matter what key I press, including the shutter button, menu, review, etc. it will not turn back on.  I have to physically turn it off then turn it back on.  This is my 5th digital eos dslr including a 7D, 7DII, 5D and 5DII, and a couple of rebels.so I am familiar whith how this should work.  I tried different lenses but no change.  I am prepared to return this one but wanted to check here first.  I have ordered open box items before and they always appear to be brand new or near brand new with no issues. Is this something that is peculiar to the 5D III?  If I am overlooking something please let me know.  I am starting to feel a little stupid about this.  

Esteemed Contributor
Posts: 4,818
Registered: ‎02-17-2016

Re: 5 D III power off issues.

Did you get yours back? 8^)

VIP
Posts: 11,807
Registered: ‎08-13-2015

Re: 5 D III power off issues.

Return it, again. 

 

But, this time include a letter stating what the serial number is of the unit you're returning is exhibiting the same issues as your prevous unit.  Phrase it in such a way as to sound helpful, as if you suspect that they may have gotten a bad batch of cameras, not as if you're suspecting that they returned the same unit back to you.  Play dumb.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Occasional Contributor
Posts: 13
Registered: ‎03-18-2016

Re: 5 D III power off issues.

Hi 32degrees!

 

To help us and the community determine what could be causing this, we'd like to ask a few questions if you don't mind answering.

 

  1.  What lens are you using on the camera when this happens?
  2.  What memory card are you using in the camera when this happens?
  3.  Does this happen without a memory card in the camera or a lens on the camera?
  4.  Have you tried clearing all of the settings in the camera back to the defaults?

Look forward to your reply!

New Contributor
Posts: 3
Registered: ‎04-05-2016

Re: 5 D III power off issues.

Thanks for the reply.  It is definitely going back.  I did more on-line research and the problem seems to be in the battery box and/or motherboard.

New Contributor
Posts: 3
Registered: ‎04-05-2016

Re: 5 D III power off issues.

It is more sporadic now.  It happens with or without lens.  Tried 3 different lenses: my tried and true 24-105, 70-200, and 24-70, 2 Lexar 32 gig memory card,  and 3 different batteries.  Memory cards and lenses don't seem to impact it.  Happens whether camera is fully dressed or not.   The last battery change seemed to help.  Camera was cleared to defaults when it arrived.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement