Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎02-16-2017

1DX MK II with TTL Flash, WFT-E8A and OVF Weird Issue

Greetings everyone,

 

This is my first time playing around with the WFT, TTL Flashes and Macro lens. I usually am a day time shooter doing sports, vehicles, and landscape/architecture.

 

Equipment: 100mm F2.8L Macro on 1DX MK2

Yongnuo 685 Flash

Yongnuo 622C TX Controller

WFT-E8A linked to iPhone Canon Connect App.

 

I was working in a low light setting and the OVF would not turn on when I was trying to switch between the LCD screen. I also found the 100mm to be really slow/bad focusing on my subject which was roughly 3 feet away from me. I found myself switching to manual focus most the time to make the photos work.

 

Anyone ever experience this, where the camera locks up on the LCD view and won't allow you to switch to OVF? It would then suddenly switch to OVF every so often as well?

 

Any input appreciated! Thanks

Highlighted
Respected Contributor
Posts: 1,076
Registered: ‎10-17-2012

Re: 1DX MK II with TTL Flash, WFT-E8A and OVF Weird Issue

Hello charbsindxb, 

 

The operation shouldn't switch between the viewfinder and the LCD panel unless initiated.  You may wish to try a different lens on the camera to see if the issue persists.  If so then you may wish to consider sending your camera in for service.  

You may fill out an online repair request form at the following link to setup your repair using our online service.

https://www.usa.canon.com/internet/portal/us/home/support/service-repair

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement