Canon Community Canon Community
 


Reply
New Contributor
Posts: 4
Registered: ‎07-21-2021

cannon rebel t7 no image and no auto focus

auto focus on, quick mode.. Image in lcd has focus points showing, but there is no auto focus when shtter is pushed halfwauy. pushed all the way shutter works..  press review it says "no image".  worked fine the last time I used it. setting is on all auto. Also flash is supposed to be disabled but pops up when shtter is pushed. I am betting it is something simple cuase I am not that smart on this stuff.

Highlighted
VIP
Posts: 8,302
Registered: ‎11-13-2012

Re: cannon rebel t7 no image and no auto focus

[ Edited ]

@Rocks wrote:

auto focus on, quick mode.. Image in lcd has focus points showing, but there is no auto focus when shtter is pushed halfwauy. pushed all the way shutter works..  press review it says "no image".  worked fine the last time I used it. setting is on all auto. Also flash is supposed to be disabled but pops up when shtter is pushed. I am betting it is something simple cuase I am not that smart on this stuff.


First, go into the menu and reset all camera settings and all custom functions. Instructions for that will be in your manual.

 

THen set camera to P(rogram) mode on the dial and go outside in daylight and try to take a picture.

 

If that doesn't clear up the problem, a few suggestions:

 

1. is there a camera club near you. Often if you go to a meeting someone might be able to help you. I know my club does that.

 

2. is there a camera store near you

 

3. here is the website for Canon support: Canon U.S.A., Inc. | Service & Repair

 

4. Midwest Camera has been recommended by some folks on this forum

 

5. Cameraworks of Colorado Springs has been recommended by folks on the Ugly HedgeHog site

 

I have no direct experience with either of them.

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic
New Contributor
Posts: 4
Registered: ‎07-21-2021

Re: cannon rebel t7 no image and no auto focus

Thanks for the info. I found some one theat knew the cmaera and he adjusted the Quick mode and it seems to be working.

 

New Contributor
Posts: 1
Registered: ‎07-28-2021

Re: cannon rebel t7 no image and no auto focus


skylightpaycard wrote:

auto focus on, quick mode.. Image in lcd has focus points showing, but there is no auto focus when shtter is pushed halfwauy. pushed all the way shutter works..  press review it says "no image".  worked fine the last time I used it. setting is on all auto. Also flash is supposed to be disabled but pops up when shtter is pushed. I am betting it is something simple cuase I am not that smart on this stuff.


 

VIP
Posts: 11,882
Registered: ‎08-13-2015

Re: cannon rebel t7 no image and no auto focus


@Raymond224 wrote:

skylightpaycard wrote:

auto focus on, quick mode.. Image in lcd has focus points showing, but there is no auto focus when shtter is pushed halfwauy. pushed all the way shutter works..  press review it says "no image".  worked fine the last time I used it. setting is on all auto. Also flash is supposed to be disabled but pops up when shtter is pushed. I am betting it is something simple cuase I am not that smart on this stuff.


 


Quick mode?  Are you using the OVF, the optical viewfinder?  Or, are using the Live View on the rear screen?

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement