Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎06-27-2020

autofucus not working

hi,

i have a eos 550D with a 18-55 is stm lens, version 2. i tried every setting on the camera but it seems that the autofocus it just does not work in video mode

it's all set to auto, the lens, in settings is set to face follow and so on. 

so i can press the shutter buttons and it's focusing, but after that it stays locked wenn i get closer or move a bit farther from the camera

at this point i might think that the body has some issues

any ideas?

i have noticed in eos utility 2 that the focus is set to remote manual , not sure what that means

Highlighted
Esteemed Contributor
Posts: 4,118
Registered: ‎02-17-2016

Re: autofucus not working

Are you focusing with live view or the viewfinder.

 

The whole point of pressing the shutter half way to lock focus is that in single shot mode, the focus won't change.

Highlighted
New Contributor
Posts: 3
Registered: ‎06-27-2020

Re: autofucus not working

eather way my problem is that the camera does not focus in video mode. i have seen videos were the subject moves in front of the camera and the camera follows. my camera does not follow me i don't care about taking images, that works fine 

video mode is the problem

Highlighted
VIP
Posts: 10,189
Registered: ‎08-13-2015

Re: autofucus not working

Your camera is working as it should.  It does not have face detection.  It does not have Movie Servo AF, which would allow it continuously autofocus in Movie Mode.  

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Highlighted
Valued Contributor
Posts: 478
Registered: ‎01-31-2017

Re: autofucus not working


@iuliancalin wrote:

it's all set to auto, the lens, in settings is set to face follow and so on. 

so i can press the shutter buttons and it's focusing, but after that it stays locked wenn i get close...


I suggest you spend some time getting to know your camera. Start here:

 

https://files.canon-europe.com/files/soft38013/manual/EOS%20550D_HG_EN_Flat.pdf

Highlighted
New Contributor
Posts: 3
Registered: ‎06-27-2020

Re: autofucus not working

i did playied alot with this camera and in the settings i found

AF mode
•d : Live mode
•c : Face detection
Live mode
•f: Quick mode

but then i found a post on this forum finally were i saw that the body can't continuos focus, even tho it had facve detection and autofocus during video

so why are those settings there

anyway, thanks for responses

Highlighted
VIP
Posts: 10,189
Registered: ‎08-13-2015

Re: autofucus not working


@iuliancalin wrote:

i did playied alot with this camera and in the settings i found

AF mode
•d : Live mode
•c : Face detection
Live mode
•f: Quick mode

but then i found a post on this forum finally were i saw that the body can't continuos focus, even tho it had facve detection and autofocus during video

so why are those settings there

anyway, thanks for responses


The "Face Detection" in your camera is an early iteration of the technology.  It works more like "human head detection" more than anything else.  The camera does not focus on eyes.  These settings are for "Live View" mode, which is used for capturing stills, not video.

 

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement