Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 6
Registered: ‎02-14-2018

XS always says "busy", won't shoot.

Hello,

 

My EOS XS (1000D), when power is on, 1/2 press of shoot button, shows in the view finderflashing  "busy" along with the eposure and iso numbers. Full press does not take a picture. This is the case in all modes, with lens on/off, memory card in/out etc. Flash pops out in the appropriate modes but busy is still there. Battery is fully charged. Please, any suggestions on what could be wrong?

Highlighted
VIP
Posts: 10,428
Registered: ‎08-13-2015

Re: XS always says "busy", won't shoot.


@ju1234 wrote:

Hello,

 

My EOS XS (1000D), when power is on, 1/2 press of shoot button, shows in the view finderflashing  "busy" along with the eposure and iso numbers. Full press does not take a picture. This is the case in all modes, with lens on/off, memory card in/out etc. Flash pops out in the appropriate modes but busy is still there. Battery is fully charged. Please, any suggestions on what could be wrong?


Try a new, freshly formatted memory card and reset the camera back to factory defautls.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement