Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎12-13-2012

T4i camera completely locking up in the ON position?

[ Edited ]

I have had my Canon T4i for about 4 months now, use ita few times a week as a hobby. Every couple weeks I will turn on the camera and adjust the Ap/Sh/ISO settings to prepare for a shoot and the camera will just freeze or lock up in the spot. None of the buttons or dials trigger any sort of response from the camera and I am not able to take a picture or do anything. Even turning th camera to the 'OFF' position does nothing and the camera remains on with the LCD still lit up but not responding. The only way I am able to get the camera working again is to remove the battery and then put it back in and power it up, at which point it usually works normally. The only time I've had this happen more than once in a day was over Thanksgiving when it happened about 3-4 times throughout the day.

 

I contacted Canon support and was told to first try resetting the camera to default settings, which I did, and if that doesn't work to remove the battery and memory cards and using a pencil eraser to clean off the contact surfaces of those items, which I have not done yet. If it continues to happen, I am supposed to send it in to let them inspect it and decide if if needs repair or replacement. Since it seems random and spread out, it's hard to say whether it's 'fixed' since it did it last week before I re-set the settings.

 

Has anyone had this problem? If so, did you do either of those methods to solve it? If you sent it in, were they able to determine the problem and handle it? I don't want to send it in and be without my camera for weeks only for them to tell me it worked fine for them and there is no problem, since it works fine 98% of the time as of now.

 

Any help would be great!

 

New Contributor
Posts: 2
Registered: ‎12-15-2012

Re: T4i camera completely locking up in the ON position?

I am having a very similar problem. The camera is locked up in movie mode. No buttons respond other than the one that allows me to view photos on the memory card. I cannot even turn it off and too have to remove the battery to shut it down only when I put the battery back, the problem has not changed. I have not reset it yet because I am not sure how. Is that in the menu?
Respected Contributor
Posts: 1,005
Registered: ‎10-23-2012

Re: T4i camera completely locking up in the ON position?

Resetting the camera to its defaults will only change settings in the menu back to their original settings.  There are no settings in the menu that would cause the camera to freeze up like this.

 

Try removing the memory card or using a different card.  You may also want to try cleaning the contacts as suggested when you called us.  If the issue still persists, your camera will need to be serviced by our Factory Service Center.

 

To start your repair process, you'll need to complete a Repair Request on our website.

 

If this is a time sensitive-matter, additional support options are available at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 1
Registered: ‎01-10-2013

Re: T4i camera completely locking up in the ON position?

I received a new T4i for Christmas and mine has locked up in the same manner several times over the last couple of weeks.  It seems to happen most when I'm adjusting/changing a setting. I have to pop the battery to get the camera back.  I'll try cleaning the contacts as suggested.  I would never think of that since it's a new camera with new battery and new mem card .

New Contributor
Posts: 3
Registered: ‎01-28-2013

Re: T4i camera completely locking up in the ON position?

We purchased this t4i in late November and started learning its functions right away. About the first time we put it in live view mode it froze up as described. The battery was fully charged and the sd card was a brand new 64 GB sdxc card. Removing the battery worked to get the camera working again. The problem seems to be associated with live view because when I put it into movie mode it also often freezes. I have not tried cleaning the battery terminals but, like others have mentioned, it seems an unlikely problem on a brand new camera.

 

It is quite disconcerting to spend as much time researching cameras, and to finally make a purchase decision and buy a camera, to find such a huge problem with the camera. I hope that Caonon will replace the camera, or perhaps Amazon, since I just bought it a month or so ago.

New Contributor
Posts: 3
Registered: ‎03-21-2013

Re: T4i camera completely locking up in the ON position?

[ Edited ]

Lockup in liveview.  Camera will not turn off, all controls are non-responsive.  Only soultion is to remove the battery.

 

Now let me ask... I've only had the camera a few days but been using it pretty heavy in order to get familiar with it.  Should I return it and roll the dice that I just got a bad unit or wait for a firmware update.  Do Canon engineers read this forum or is this just a playcation by Canon to vent frustrations?

New Contributor
Posts: 3
Registered: ‎01-28-2013

Re: T4i camera completely locking up in the ON position?

Yes, return it. We returned ours, got a new one, and haven't had a recurrence of the problem.

Frequent Contributor
Posts: 40
Registered: ‎11-30-2012

Re: T4i camera completely locking up in the ON position?

Well my camera just came back from Canon service for an unrelated issue  and went through all the quality checks and today it locked up after going to movie mode then later in the day it did it again after going to movie mode and the only way to shut it off was to remove the battery. Camera Firmware Version is 1.0.1 and the lens attatched was the 18-135 IS STM Lens firmware version 1.5.0. Camera was purchased in November 2012.

Bob


IMG_9314.JPG

"Cameras don't take pictures, photographers do."
Product Expert
Posts: 978
Registered: ‎10-16-2012

Re: T4i camera completely locking up in the ON position?

Hi Bobakman,

 

I recommend you contact us via telephone or email.  For contact options, please click here.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Frequent Contributor
Posts: 40
Registered: ‎11-30-2012

Re: T4i camera completely locking up in the ON position?


@Richard wrote:

Hi Bobakman,

 

I recommend you contact us via telephone or email.  For contact options, please click here.


Thanks I am currently in an E-Mail support conversation and am using a different SD card to see if it may be related to the specific card.

 

Bob

"Cameras don't take pictures, photographers do."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement