Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎07-15-2018

T4i Autofocus Issues

Hi everyone,

I purchased my T4i new back in about 2012.  It's been a great camera but within the last couple weeks I've been having autofocus issues.

 

The camera won't focus on anything further than about 10 feet away (though every once in a while it will start working for a few hours before stopping again.)  Most of the time (but not always) the camera will focus on close-up items just fine.  The focus motor does appear to be working as it will 'hunt' trying to lock focus, it will just never lock.

 

This happens with both my 55-250mm lens and my 18-55mm lens.  I have tried cleaning the gold contacts on the camera and lenses, and I have ensured the autofocus switch is in the correct position.  I did try resetting all settings and I have tried multiple shooting modes (auto and manual).

 

I am running firmware 1.0.1 on the camera and 1.0.0 on the lens.

 

Anyone else run into this or have any suggestions?

VIP
Posts: 8,643
Registered: ‎08-13-2015

Re: T4i Autofocus Issues

Try resetting the camera back to factory defaults, by using the menu selections.  Go outside on a bright sunny day, remove any lens filters, set the camera to Green [A] mode, and see if it works.  If it still fails, then your camera may be bad.


----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
VIP
Posts: 11,674
Registered: ‎12-07-2012

Re: T4i Autofocus Issues

"I have tried cleaning the gold contacts on the camera and lenses ..."

 

And like most people find out that never to rarely helps.  Stop doing it as you can damage the contacts way more than any help it may do. It is the lens that focuses not the camera.  However, you said you tried two lenses.  Are you sure the 55-250mm doesn't work?  The standard kit lens, 18-55mm is notorious for having focus problems.

All you can do is clear all settings under the Tools menu.  Set it to a auto mode, P or green square and try under good outdoor sunny conditions.  Both lenses.  Also try to find something with good contrast.  Fence posts for instance.

 

If it still doesn't work correctly call 1 (800) 652-2666 for service info.

EOS 1DX and 1D Mk IV and several lenses!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement