Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎08-05-2013

T3i and Novatron strobes not firing

Okay, so my previous posts as well as my user account was deleted, so I'm starting again, 


I have a new T3i that I'm trying to use with two Novatron 150 strobes. I am using a pc converter in my hot shoe to wire the strobes to my camera. The strobes work, the pc cord is fine, the hot shoe works, I've tried two different pc converters, and yet the strobes won't fire when I take a photo. I've tried it on Manual, Auto, Program, all with the live vid disabled. Under flash options, I've tried both with the camera's flash enabled and disabled. There's gotta be a setting or something that I've not got right. HELP! I'm totally frustrated.
 
Esteemed Contributor
Posts: 3,809
Registered: ‎06-11-2013

Re: T3i and Novatron strobes not firing

What have you done so far to diagnose?   For example... you mention that you have the PC converter and sync cord and that they're both working, but you don't mention how you know that.

 

Do you have other flashes that DO work when connected (i.e. is it just these particular flashes)?  Have you tested a speedlight directly in the hot-shoe?  

 

You could test the camera's hot-shoe itself if you own a multi-meter that can measure resistance (ohms).  Firing a flash manually is trivial.  The main pin is that large center contact you see in the hot shoe.  The metal ground rails themselves are actually the other pin.  To fire a flash manually, the camera just needs to short the connection (to complete the circuit) between those two pins.   If you happen to own a multi-meter / ohm-meter (mine has a mode that beeps when the connection is completed which makes it really easy to tell if it happended) you can connect the leads to those two contacts and activate the shutter button to see if the connection closes (it should... it'll be very brief, but it should happen.  As I said... my meter "beeps" so I can audibly hear that it happened without looking.)  You could also use the ohm-meter to test your PC-sync cord adapter and the cord itself.

 

Tim Campbell
5D III, 5D IV, 60Da
New Contributor
Posts: 1
Registered: ‎06-05-2014

Re: T3i and Novatron strobes not firing

Did you ever figure out your issue? I have been given the use of a Novatron 1000 kit. Like you I've purchase the sync cord and hotshoe adapter. I couldn't find anything in the manual about the internal camera settings.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement