Canon Community Canon Community
 


Reply
Respected Contributor
Posts: 1,861
Registered: ‎12-02-2012

Re: Red focal points no longer showing in viewfinder

Is it possible that the AF/MF switch on the lens has accidentally gotten flipped from Autofocus to Manual Focus?  That will turn the little red lights off, and it can be a little confusing when it happens. 

Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?
Honored Contributor
Posts: 6,003
Registered: ‎11-13-2012

Re: Red focal points no longer showing in viewfinder

I thought of that, but I tested it on my T5i and 1D Mark IV  and they do light up in MF and it will beep when focus is achieved. Is that new for later models than T3i?

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Respected Contributor
Posts: 1,861
Registered: ‎12-02-2012

Re: Red focal points no longer showing in viewfinder

[ Edited ]

No idea but I do know from personal experience that when the AFMF switch on my Sigma 35mm lens gets bumped to MF, the red points are not visible in the viewfinder of my 6d.  

 

Perhaps they would appear, and/or beep if I was doing it on purpose, and I was manually focusing, but it seemed like the OP would not have been intentionally doing manual focus.

Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?
Honored Contributor
Posts: 6,003
Registered: ‎11-13-2012

Re: Red focal points no longer showing in viewfinder

I was using Canon lens.
John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎08-28-2015

Re: Red focal points no longer showing in viewfinder

Trying this now. Will let you know how it goes.

 

To the other questions:

- works fine in all modes (I shoot in M all the time)

- other indicators in the viewfinder are working fine

- AF is on all the lenses

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement