Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎04-18-2019
Accepted Solution

Recording issue

I have a EOS rebel T3 that pretty old but never had any problems with it until yesterday. In the middle of me filming something for my class project the screen start to glitch and the camera froze so i had to remove the battery to completely turn it off and put it back to turn it on. Now everything else works however every time i try to record anything it was glitch up and my camera will freeze. I tried making sure it was charged but idk what else to to everything works normal until i press the record button.
Esteemed Contributor
Posts: 3,174
Registered: ‎02-17-2016

Re: Recording issue

Try a new SD card, of the correct speed value, and formatted in the camera.

Valued Contributor
Posts: 397
Registered: ‎02-13-2016

Re: Recording issue

Are you using a full size SD card or a micro SD card with an adapter? Have you formatted the memory card in the camera recently? Ever?

New Contributor
Posts: 3
Registered: ‎04-18-2019

Re: Recording issue

I’ve used both my full size and Micro sd card and formatted both. I used both lenses i have which are 75-300mm and EFS 18-55 and i still get the glitchy screen idk what else to do
New Contributor
Posts: 3
Registered: ‎04-18-2019

Re: Recording issue

The issue haven’t hasn’t been solved ignore that post
Esteemed Contributor
Posts: 3,174
Registered: ‎02-17-2016

Re: Recording issue

Don't use the micro SD. Other than that, you might try calling Canon and they can talk you through some things to try.

Esteemed Contributor
Posts: 3,174
Registered: ‎02-17-2016

Re: Recording issue

Did you low level format?

 

Untitled.jpg

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement