Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎08-25-2015

Rebel t5i stuck in video mode.

I have a Rebel t5i and it seems to be stuck in video mode. Even when I turn the camera off, it stays on in the video mode.

 

I have tried:

- taking out the battery (as soon as I put it back in the camers, video mode comes back on regardless of whether the camera is on or off)

-clearing the settings on the camera

- updating the firmware on the camera

 

Any other suggestions or reasons this may be happening? I just bought the camera in June!

 

 

Highlighted
Honored Contributor
Posts: 6,822
Registered: ‎11-13-2012

Re: Rebel t5i stuck in video mode.

Try removing battery, turn camera on, leave battery out overnight.

If that doesn't work I'm guessing its a mechanical problem with Off/On/Video switch.
John Hoffman
Conway, NH

1D X Mark III, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LR Classic
Highlighted
New Contributor
Posts: 2
Registered: ‎08-25-2015

Re: Rebel t5i stuck in video mode.

hmmmm....that didn't work either....thanks for the advice though!

Highlighted
Honored Contributor
Posts: 6,822
Registered: ‎11-13-2012

Re: Rebel t5i stuck in video mode.

Contact Canon service. It should still be under warranty. 

John Hoffman
Conway, NH

1D X Mark III, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LR Classic
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement