Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎11-17-2015

Problem with t5 after using external flash camera wont take picture with built in flash

About 3 months ago i bought the T5 kit with the two lenses.  After noticing that the cameras flash kills the battery after about 50 shots i decided to buy an external flash flash.

 

camera works fine with the external flash.  The promblem is however when the external flash isnt connected, the popup flash will fire like 5-10 times in rapid concession but wont take a picture. Regardless of the setting.

 

connect the external flash, no prob.  If the camera decides it doesnt need the flash itll take pics with out the external flash.

 

not sure why its doing this?

Highlighted
Honored Contributor
Posts: 7,018
Registered: ‎11-13-2012

Re: Problem with t5 after using external flash camera wont take picture with built in flash

If its dark enough to need flash its probably too dark for autofocus to work without helper beam.

 

That is whats happening; the flash is creating extra light to help focusing. Your external flash probably has a focus assist light as well.

 

You can control it via custom function:

 

Capture.JPG

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic
Highlighted
New Contributor
Posts: 2
Registered: ‎11-17-2015

Re: Problem with t5 after using external flash camera wont take picture with built in flash

Thank you, ill try that.

 

outside of that i really love this camera!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement