Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎11-10-2019

Pop up flash not working

EOS 500D (Rebel). When I try to select built in flash, I get the error message saying not available - external flash attached, when there is no external flash attached.  The external flash works fine. Can anyone help please?

 

IMG_2202.JPG

Reputable Contributor
Posts: 777
Registered: ‎12-24-2013

Re: Pop up flash not working

[ Edited ]

There is a small microswitch sensor under the hot shoe rails which senses when a flash is attached. It is there to prevent the built-in flash from popping up when an external flash is attached. It must be sticking or malfunctioning. 

 

You could try try cleaning the  Hotshoe rails. 

 

F39C1B54-7EB0-4C5E-89D0-4DD889EB832B.jpeg

Mike Sowsun
S110, SL1, 80D, 5D Mk III
New Contributor
Posts: 2
Registered: ‎11-10-2019

Re: Pop up flash not working

Fixed! The micro switch was indeed stuck and I’d never have known it was there, it hidden under the plate spring where it is.

I’m very grateful for the help. Thanks
Occasional Contributor
Posts: 9
Registered: ‎11-10-2019

Re: Pop up flash not working

Hi Mike,

 

New here and didn't find a way to post a question. Can you post here and let me know?

 

Thanks,

 

Tom

Honored Contributor
Posts: 6,235
Registered: ‎11-13-2012

Re: Pop up flash not working

Each section has a button like this:

 

Annotation 2019-11-10 190054.jpg

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LR Classic
Occasional Contributor
Posts: 9
Registered: ‎11-10-2019

Re: Pop up flash not working

Thanks John

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement