Canon Community Canon Community
 


Reply
Highlighted
Esteemed Contributor
Posts: 3,847
Registered: ‎06-11-2013

Re: Pictures Very Dark

Bizarre... they both show the identical exposure settings of:

 

Auto exposure, Program AE, 1/64 sec, f/4, ISO 400.

 

But then in the filesize... both indicate same resolution & JPEG and "17.9 megapixels"... but one indicates it saved to disk at 3.6 MB and the other saved to disk at 7.2 MB.  That part seems a bit odd.

 

But as the exposure data reads the same, then it should look the same (unless the lighting was changing on you between shots.)   Were you in a sitatuion where lights were changing?

 

One other possibility... 

 

It's possible to point the camera at one area, half-press (and hold) the shutter button (this locks in the metering) and then point the camera at a different subject before fully pressing the shutter to take the shot.  If you were do this, then you'd get the "metering" locked in from the first subject.

 

 

Tim Campbell
5D III, 5D IV, 60Da
Highlighted
Occasional Contributor
Posts: 6
Registered: ‎07-28-2015

Re: Pictures Very Dark

I agree.  Totaly the same except file size.

 

what is really throwing me for a loop, is this just started happening out of no where.  This totally worked fine, but a week or 2 ago, this started.

 

None of the other suggestions have worked yet.

 

Thanks again for all the help.

 

Steve

Highlighted
Honored Contributor
Posts: 5,552
Registered: ‎06-25-2014

Re: Pictures Very Dark


@TCampbell wrote:

Bizarre... they both show the identical exposure settings of:

 

Auto exposure, Program AE, 1/64 sec, f/4, ISO 400.

 

But then in the filesize... both indicate same resolution & JPEG and "17.9 megapixels"... but one indicates it saved to disk at 3.6 MB and the other saved to disk at 7.2 MB.  That part seems a bit odd.

 

But as the exposure data reads the same, then it should look the same (unless the lighting was changing on you between shots.)   Were you in a sitatuion where lights were changing?

 


That could happen if the light source is low-persistence fluorescent bulbs on alternating current. Note that the shutter speed is comparable to the AC frequency (usually 60 Hz in North America, 50 Hz in much of the rest of the world). When a fixture has two or three tubes, electricians usually try to wire them out of phase to lessen the effect, but that's not always feasible. It's a longshot explanation, but not entirely improbable.

Bob
Philadelphia, Pennsylvania USA
Highlighted
VIP
Posts: 13,043
Registered: ‎12-07-2012

Re: Pictures Very Dark

[ Edited ]

"None of the other suggestions have worked yet."

 

And none of these are going to work either.  There is something else going on.  But we need to do the most logcial ones first.

Get a new high quality SD card.  Format it in the camera. A new battery might be a good idea, too.  Canon of course.

 

 Do go outside where there will be plenty of light.  Take some shots.  No flash.

If your camera requires service, Canon is going to do this so you might as well save them from doing it. Right?

 

It is obivious the camera thinks it has done its job.  The fact the files are different sizes is because there is different content in each.

Do the daylight test with a new SD card.  Seeing the same results, take it in for service with the lens.

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
Reputable Contributor
Posts: 790
Registered: ‎06-11-2013

Re: Pictures Very Dark

[ Edited ]

....

 

That said, I have always used the Auto setting on the camera.  Up to 2 weeks ago, this worked perfectly fine.  In the last 2 weeks every other picture is very dark.  The ones that are not dark, are perfect.  So weird.  So dark i can not even use.  However I am 100% sure the flash is going off.

...

 

 


I am assuming you are using the camera's built in flash for all your shots.

 

That being the case, since "every other picture" is dark, it might just be that the flash is not fully recycled ("recharged") before you take the "dark" shot. This could be because the camera's battery is getting older, less efficient than it was originally (since the built in flash uses the camera's main battery for power... one of the things I hate about built in flashes!).

 

Simply shooting too fast with flash can cause underexposure issues. But you might speed things up a little by getting and using a new battery.

 

There may be a setting in the camera that allow or prevent the camera from firing when the flash is insufficiently charged up. If allowed, it would be entirely possible that some of the images might be underexposed.

 

I don't think the different file sizes means anything... in digital images white is "all data" and black is "no data"... so an extremely underexposed image would naturally end up as a much smaller file than one that's properly exposed.

Highlighted
Honored Contributor
Posts: 5,552
Registered: ‎06-25-2014

Re: Pictures Very Dark


@scusick wrote:

I cant find the reset setting in the Menu if you can assist please.

 

I can 100% see the flash go.  maybe it igoes, but not working?

 

and this worked perfectly for months, and all of a sudden it changed.

 

Another interesting thing I just noticed.  The good ones are like 7 and 8 MB.  The bad ones are only 3-4 MB.  Could that be a hint as to the problem?

 

Let me know if these attachment helps.  

 

Thanks in advance

Steve

 


The file size discrepancy is a consequence of the problem, but says nothing about its cause. You're evidently shooting JPEG images, and the algorithm that translates the RAW capture into JPEG format uses data compression when it can. When an image is monochromatic and/or has little detail, the compression is more efficient. Since an image that's nearly all black has little detail, the result is a smaller file.

Bob
Philadelphia, Pennsylvania USA
Highlighted
Frequent Contributor
Posts: 73
Registered: ‎07-19-2014

Re: Pictures Very Dark

[ Edited ]

NERD ALERT

 

https://www.google.com/patents/US6456797

 

TL;DR - 

 

Canon has patents on a system of charging the flash capacitors in parallel. So every other flash alternates from a different electrical "side." One of your sides is not charging properly, and only putting out maybe ~10% of what it should.

 

The upshot: send the camera in for service, for variances in flash output.

______________________________
I'm a cinematographer in Chicago using mostly Canon gear. I also founded MKE Production Rental in Milwaukee.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement