Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎07-22-2015

No CF card error - card is fine on PC though

Hi all,

 

I have a EOS 300D (yes I know it's old, but it's good)

 

Since I last took the card out to transfer everything to my PC, I'm getting "No CF card" error when the card's in.

 

At first I thought it must be the card, but I've since put it on a card reader, and it seems absolutely fine.

 

I've reset all the camera settings, and tried to format the card, but it won't read it at all.

 

Any ideas or help please?

Highlighted
Honored Contributor
Posts: 6,832
Registered: ‎11-13-2012

Re: No CF card error - card is fine on PC though

That happened to my Digital Rebel (US version of 300D) and it turned out there was a bent pin in card slot.
John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic
Highlighted
New Contributor
Posts: 2
Registered: ‎07-22-2015

Re: No CF card error - card is fine on PC though

Thanks John, I've since seen this problem reported on here for different models. How annnoying, looks like it's off for repair then. Just when I really needed it too Robot Sad

Highlighted
VIP
Posts: 12,892
Registered: ‎12-07-2012

Re: No CF card error - card is fine on PC though

Get an estimate first!    It may cost more to repair it than its worth.  Smiley Frustrated

EOS 1DX and 1D Mk IV and several lenses!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement