Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎10-25-2013

My brand new T3i wont take any picutres

I just got my T3i/600D. The camera turns itself off when I press the shutter button to take a picture. It will not turn back on until I take out the battery and put it back in. The same happens with the live shooting button.

I tried with 2 different SD cards and batteries. Same result.

I have seen similiar questions in the forum but I was not sure if it the same problem.So please redirect me if this same problem was discussed before.

 

I bought the complete bundle but I could not take a single picture. I am very disappointed and looking forward to your help.

 

Thank you,

Yetkin

Respected Contributor
Posts: 1,005
Registered: ‎10-23-2012

Re: My brand new T3i wont take any picutres

Hi ozkucur!

 

Thank you for posting about this.

 

It is not normal for the camera to shut itself down when you press the shutter button.  If it continues to happen even after you remove and reinstall the battery, the camera will need to be serviced.

 

To start the repair process, you'll need to complete a Repair Request on our website.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Occasional Contributor
Posts: 5
Registered: ‎10-25-2013

Re: My brand new T3i wont take any picutres

After calling the Canon support, I returned the camera and got a new one. It works now.

Thanks,

Yetkin

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement