Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎02-01-2013

I keep getting an error 05 code on my t31 and turning the camera off and back on does not work.

I keep getting an error code 05 when I try to use certain modes on my Rebel T3i.  It seems as though my auto flash is stuck.  Is this a common complaint....and if so.....what is the answer to deal with this issue.  I have followed the instructions of turning the camera off and back on....to no avail.  HELP!!

Product Expert
Posts: 978
Registered: ‎10-16-2012

Re: I keep getting an error 05 code on my t31 and turning the camera off and back on does not work.

Hi Hydra171,

The Error 5 error code indicates a malfunction in the popup flash mechanism.

 

If this is not cleared by turning the camera off, then on, your camera will require service to correct this issue.

 

You may set up the repair for your camera here.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Highlighted
Occasional Contributor
Posts: 10
Registered: ‎11-13-2012

Re: I keep getting an error 05 code on my t31 and turning the camera off and back on does not work.

I've gotten a number of error 5's myself but it was a simple case of bumping the flash pop up button while the camera was in such a position as to prevent the flash from popping up.  (it was tucked into my jacket)  Are you having the issue while the pop up flash is clear from obstructions?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement