Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎04-30-2019

HELP!!!!!!!!!! Battery seems to be dead...but when put into another camera is charged

[ Edited ]

I own a EOS t5i camera with an LP-E8 battery pack. When I insert the battery into the camera, the screen reads "Change the battery pack" with a dead battery symbol. Yet, when I insert the same battery in an identical t5i, it shows that the battery is completely charged. Therefore, I believe there is a problem with the battery and/or the original camera. Please help!!!!!

Respected Contributor
Posts: 1,317
Registered: ‎03-01-2014

Re: HELP!!!!!!!!!! Battery seems to be dead...but when put into another camera is charged

Oh boy! Take a look inside your battery compartment, see if any of those metal battery contacts look damaged or dirty. It sounds like the battery is ok or it wouldn't work in the other T5i.

Product Expert
Product Expert
Posts: 914
Registered: ‎10-17-2012

Re: HELP!!!!!!!!!! Battery seems to be dead...but when put into another camera is charged

Hello sarahnruthphoto, 

 

We are sorry that this issue happens.  We recommend sending the unit into the Factory for evaluation. 

You may fill out an online repair request form at the following link to setup your repair using our online service.

https://www.usa.canon.com/internet/portal/us/home/support/service-repair

  

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement