Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎01-02-2019

Flash is malfunctioning

My flash in my Rebel SL2 seems to be malfunctioning. When I try to use the feature the flash will pop up to flash but the flash never happens. I don’t know if I mistakenly made this happen or the flash lens is broken. Please help!
Honored Contributor
Posts: 5,653
Registered: ‎11-13-2012

Re: Flash is malfunctioning

If you think you selected something in error you can go into the menu ystem and select the option to reset camera to factory settings.

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Frequent Contributor
Posts: 83
Registered: ‎05-25-2018

Re: Flash is malfunctioning

[ Edited ]

I am not normally a fan of using the pop-up flash because the flash is too harsh, but I would go with what jrhoffman says, and/or call 1-800-652-2666 for a repair.

 

Another non-orthodox solution perhaps is buying previous generation 430-ex ii on the used market because the cost of repairing the pop-up flash might be more than buying a used speedlight assuming the repair cost is $150-$200.

Andrew
Nature Photography Hobbyist / Enthusiast
Canon EOS Rebel T6i
VIP
Posts: 11,002
Registered: ‎12-07-2012

Re: Flash is malfunctioning

It is possible the flash tube has burned out.  You single option before calling Canon is to reset the camera in the menus under the tools tab.

EOS 1DX and 1D Mk IV, even less and less other stuff.
New Contributor
Posts: 2
Registered: ‎02-12-2019

Re: Flash is malfunctioning

I have the same problem and I made a video to show you guys. Unfortunaly I am outside of the us and cant refer to the support service right now.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement