Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎02-10-2019
Accepted Solution

Firmware Bug?

[ Edited ]

I upgraded the firmware in my T5i from 1.1.3 to 1.1.5 and now the LCD screen blinks off for 1 or 2 seconds about every 30 seconds. It seems to be worse when set to 'P' mode. I don't remember the camera acting like this before the upgrade. Can I go back to 1.1.3 or reload the 1.1.5?

EDIT:

Tipping the camera up makes the display go out. Move the camera and the display comes back on. Aiming at a lamp and it seems to stay on. Light related? Time out due to not being used? LCD stys on when set to lilve shooting.

Esteemed Contributor
Posts: 3,228
Registered: ‎02-17-2016

Re: Firmware Bug?

[ Edited ]

There is a light sensor that turns off the LCD when your eye is at the camera. Make sure that the eyecup is firmly seated and not blocking the sensor.

Highlighted
VIP
Posts: 10,921
Registered: ‎12-07-2012

Re: Firmware Bug?

"I upgraded the firmware in my T5i from 1.1.3 to 1.1.5..."

 

It is not necessary to upgrade FW unless there is a reason to. For instance and upgrade to lenses supported and you have one of the lenses. Sometimes, but very rarely, FW adds a new feature so that would be a good reason. Otherwise you probably won't receive any benefit from doing so.

EOS 1DX and 1D Mk IV, even less and less other stuff.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement