Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 7
Registered: ‎02-07-2017

EOS T2i Video Mode Issue

[ Edited ]

When in video mode with my T2i that I just recieved from ebay, The video it shoots is extremely dim (were talking pitch black with a few highlights) with iso 100 in a fairly lit room. I have to crank it to iso 6400 to get any decent results which should not be the case for the room im in. My settings are, iso 100, 1080p @24fps, shutter @1/50, F3.5, Everything set to manual, and custom whitebalance. I don't believe it's my SD card since if I take it out, the same results occur. In picture mode with iso 100 the lighting is fine. What is strange is that if I try holding the image capture button (the button used to take photos) when using AF, the lighting jolts up to being very usable, but if I let go it goes back to being basically black. Please help.

Occasional Contributor
Posts: 7
Registered: ‎02-07-2017

Re: EOS T2i Video Mode Issue

I should also mention that the SD card is a sandisk ultra 32gb

Occasional Contributor
Posts: 7
Registered: ‎02-07-2017

Re: EOS T2i Video Mode Issue

One last thing. When in video mode with no lens, it is just fine, and the lens itself is also plenty bright, but for some reason when you combine the two it is very dark. Could it be a firmware issue?

Honored Contributor
Posts: 5,983
Registered: ‎11-13-2012

Re: EOS T2i Video Mode Issue

In the same lighting conditions set the camera to manual mode, f/3.5, 1/50 shutter speed and see what ISI you need for correct exposure.
John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Occasional Contributor
Posts: 7
Registered: ‎02-07-2017

Re: EOS T2i Video Mode Issue

 

Thanks for the reply! When in manual mode for photos, I get the same results as for video. Extremely dim photos.IMG_0903[1].JPG

Honored Contributor
Posts: 5,983
Registered: ‎11-13-2012

Re: EOS T2i Video Mode Issue

Is this what you get when the exposure meter in the viewfinder is at the center point?
John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Occasional Contributor
Posts: 7
Registered: ‎02-07-2017

Re: EOS T2i Video Mode Issue

Yes. The exposure meter is at the center point.
Honored Contributor
Posts: 5,983
Registered: ‎11-13-2012

Re: EOS T2i Video Mode Issue

What happens if you select P mode?
John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Occasional Contributor
Posts: 7
Registered: ‎02-07-2017

Re: EOS T2i Video Mode Issue

Normal photos with iso 100
Honored Contributor
Posts: 5,983
Registered: ‎11-13-2012

Re: EOS T2i Video Mode Issue

Since no one else has chimed in give Canon a call at 1-800-OK-CANON. I don't know enough about movie mode.
John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement