Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎11-21-2020

Canon t6i not metering properly?

Okay. We've wiped all settings. Custom. Camera. 

I'm even shooting just in auto the camera automatically sets the exposure to -3 

 

even if outside in extremely bright light. 

 

our camera dealer has went downhill. They told me to update the firmware. 

we did that and it still didn't fix the issue. 

I have been on hold for over an hour with canon and cannot get through. 

 

thanks in advance. 

Highlighted
Respected Contributor
Posts: 1,181
Registered: ‎01-25-2018

Re: Canon t6i not metering properly?

[ Edited ]

Exposure compensation has been accidentally set on your camera.  To set it back to 0, first set the program to one of the creative zones besides M using the mode control knob on the top of the camera.  Choose P, Av, or Tv.  Then while holding down the Av +/- button (back of your camera near the upper right corner of the LCD screen) turn the main dial on top of the camera to set exposure compensation back to 0.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video
Highlighted
Honored Contributor
Posts: 7,163
Registered: ‎11-13-2012

Re: Canon t6i not metering properly?

[ Edited ]

@diannaleigh wrote:

Okay. We've wiped all settings. Custom. Camera. 

I'm even shooting just in auto the camera automatically sets the exposure to -3 

 

even if outside in extremely bright light. 

 

our camera dealer has went downhill. They told me to update the firmware. 

we did that and it still didn't fix the issue. 

I have been on hold for over an hour with canon and cannot get through. 

 

thanks in advance. 


Rodger's advise is the correct approach to address unexpected camera behavior.

 

but, severail things confuse me:

 

1. you say this happens in Auto. Exposure Compensation isn't available in Auto; only in the Creative Modes.

 

2. you say exposure is -3. Do you mean it is at the bottom of the vertical scale?

 

Did this just happen suddenly? Did anything happen to the camera?

 

Can you post a JPEG with the EXIF data attached? Or send me a file in a PM?

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, MX472, LR Classic
Highlighted
VIP
Posts: 13,287
Registered: ‎12-07-2012

Re: Canon t6i not metering properly?

"Okay. We've wiped all settings. Custom. Camera."

 

I would do this again. Menus, tools, clear all settings and all custom settings. Now set the T6i to P mode, ISO 200, One shot and just the center focus point. WB to daylight. Now on a nice day go out side and take several shots of general subjects some with vertical lines in them like tree, fence or buildings, etc.  If all is good the camera is OK. Yeah, I know but do this test anyway just to confirm the T6i is working properly.

 

"our camera dealer has went downhill. They told me to update the firmware."

This is too bad but the advise was also bad.  Updating the FW on a suspected faulty camera is really bad advice.

 

 

EB
EOS 1DX and 1D Mk IV and several lenses!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement