Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎05-02-2019

Canon T5i Autofocus slowed to a crawl???

I have a 18-250mm Sigma lens attached to my camera - the camera has worked fine, but over the last week, when I've shot pictures both inside and outside, the autofocus seems to take forever. The battery is fine, and I'm using a class "U3" card. This happens when shooting video or photos - the photos look fine, but the video - since the focus points change, has some weird spots in the middle.

I've checked the lens seating, I do have a Merkury Optics 62mm glass lens cover...

OS is set to "on" and the AF/N is set to "AF"

If anyone has any idea as to why my AF has slowed to a crawl, I would greatly appreciate it - I'd love to take it to the hockey game tomorrow night and actually get faster shots. Thanks!

Highlighted
VIP
Posts: 8,594
Registered: ‎08-13-2015

Re: Canon T5i Autofocus slowed to a crawl???

You need to do some basic troubleshooting.  But, first make sure that you have sufficient light for the camera to focus.  If you are using any telextenders, remove it.  Remove the lens filter, too.

 

Still not working, then try a different lens.  Did the problem go away?  If so, then the problem is probably the Sigma lens.  If the problem is still present with a different lens, then try another lens.  You need to tigure out is the lens, or the camera.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
VIP
Posts: 11,642
Registered: ‎12-07-2012

Re: Canon T5i Autofocus slowed to a crawl???

First throw the Merkury Optics 62mm filter just as far as you can over a deep body of water. Second reset your camera to factory default.

" I'm using a class "U3" card."  This has no impact on focus except it needs to be a top quality brand (Sandisk, Lexar, Transend, etc) bought from a a top retailer for proper camera operation..  Amazon or ebay is not a top retailer, BTW.  To much junk and counterfeits there.

The Sigma 18-250mm is not a stellar lens. It is in the OK catagory but not a real good lens.   It will be slow when it doesn't get good lighting. That is normal. It will be slow if you ask it to focus from very near to very far. Perhaps it will not focus at all. This is normal for that lens and even other lenses of such a huge focal range. IMHO, would rather see you get a Canon lens perhaps the Canon EF-S 18-135mm f/3.5-5.6 IS STM or EF-S 55-250mm f/4-5.6 IS STM Lens.  Yeah, a bit less FL (long or short) but they are a whole lot better and all Canon.

 

"If anyone has any idea as to why my AF has slowed to a crawl,..."

Remember it is the lens that focuses, not the camera. If it has changed from what you used to see, the lens is probably faulty.

 

"The battery is fine."

Good. Smiley Happy

EOS 1DX and 1D Mk IV and several lenses!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement