Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎02-25-2016

Canon T2i - Video mode makes the camera stop working

Hi guys,

I have a T2i, which I recently had to take to the repair center due to some issues with the memory card chip. However, now everytime I put it into video mode, the screen turns black and the camera stops working altogether. To make it work again, I have to remove the battery and turn it on again. After that, there's a sound as if the shutter was stuck. 

 

All the information I've found is about the "Recording was stopped automatically" message, but this isn't the issue here. 

 

Does anyone know what should I do about this?

Thank you!

Super Contributor
Posts: 154
Registered: ‎01-13-2015

Re: Canon T2i - Video mode makes the camera stop working

[ Edited ]

Did you install the Magic Lantern ?

 

Have you tried using a new card ?

 

Try clear all camera settings and clear all Custom Tunc. (C.Fn)

New Contributor
Posts: 2
Registered: ‎02-25-2016

Re: Canon T2i - Video mode makes the camera stop working

Thanks for your reply! 

So I haven't installed any add-ons and I did try using a new card. 

I just tried the last option, clearing all settings, but it's not working. 

Super Contributor
Posts: 154
Registered: ‎01-13-2015

Re: Canon T2i - Video mode makes the camera stop working

If so, you may have to send it in for repair. However the cost will be close to buying a second hand T2i. May be it's time to consider an upgrade.
Esteemed Contributor
Posts: 3,342
Registered: ‎02-17-2016

Re: Canon T2i - Video mode makes the camera stop working

It might still be under the warranty for the first repair.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement