Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 8
Registered: ‎09-03-2014

Canon Rebel locks up,

 Hey guys! This is my first post so let me start off by saying, greetings! But now to the meat. I have a Canon Rebel t3. a few days ago something really weird happened. I hope maybe somebody had a similar experience, and figured it out. Ok, whenever I take a photo (and seems as if it doesn't matter what mode. I've tried this in landscape, portrait, no flash, with flash, autofocus on, manual focus on, etc) the same fires, but then instantly locks up. The screen goes black. None of the buttons respond. And the little red LED comes on and is solid. There is no way I've found to get the camera out of this 'dead-mode' except for doing a battery pull. If I open the battery lid, the camera beeps I guess to warn me that I'm about to pull the battery while it's on. So I suppose it is 'on' but it's in the dead state I just previously described. So I pull the batt and put it back in and the camera comes back on. The screen works. And all the menus and settings are accessible. If I check to see if that photo I just tried to take was recorded, it never is. All my old photos I took BEFORE this weird circumstance are still saved. So If I go back and try to take a photo the cycle starts again. The camera fires, the screen blacks out, the red LED is solid, none of the buttons are responsive. Even flipping the on/off switch to the 'off' position and then back the 'on' position has absolutely no effect. So I have to pull the battery and that wakes the camera up. How weird is that? I don't have very much experience with cameras but this is what has happened to me. I've tried to include all the relevant information. If I left anything out please ask me and I'll be glad to try and fill in any holes. But uhh, does anyone have an ideas as to why this is happening? or how to fix this? I really wanna take pictures and it defintely sucks not being able to. Thanks in advance for any help.  

Respected Contributor
Posts: 1,861
Registered: ‎12-02-2012

Re: Canon Rebel locks up,

It isn't clicked over to video shooting mode, is it?
Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?
Esteemed Contributor
Posts: 3,815
Registered: ‎06-11-2013

Re: Canon Rebel locks up,

First... which Canon Rebel model camera do you have?

 

Second... the red led light indicates the camera is trying to use the memory card.  Do you have another card?  It's possible the card you are using is having a problem when the camera attempts to save an image to the card.

 

The on/off switch is a "soft" switch.  It doesn't actually cut power... it just tells the camera you selected the "off" position and the firmware tells the camera to go to an "off' state which is more like an extended sleep mode (it's similar to your TV... when you turn it "off" it's not really completely off becuase part of it is still "on" waiting for a signal from the remote control telling the TV to swtich itself back "on".)  Pulling the battery obviously deprives it of power so that when the battery is re-inserted it's forced to reboot fresh.

 

 

Tim Campbell
5D III, 5D IV, 60Da
Occasional Contributor
Posts: 8
Registered: ‎09-03-2014

Re: Canon Rebel locks up,

Scotty, the camera isn't in video mode. I don't think this camera has a video mode. Campbell, it's the Canon EOS Rebel T3. I thought it was the memort card at first as well. I've switched it out with another one I have, to test out. It behaves the same way with the other memory card. It turns on, and I can check the files/photos on the card. But whichever mode I switch to (most the time I'm in 'flash off' mode and using manual focus) sports, portrait, landscape, closeup, the minute I take that photo the camera dies. I have the pull the batt and it does come back on. It can still read the other card and show me my photos. But the one I just took, that made the camera lock-up was not recorded. But yeah, I did try and alternate card. It behaves the same.. sucks. I would post a youtube video of it. But it pretty much would just be a video of everything I just explained. lol. idk. The only thing I didn't try would be to use a different lense. I do have one. But the lense wouldn't cause this problem would it? idk. I'll give it a try today. Everything is worth a shot at this point. 

Occasional Contributor
Posts: 8
Registered: ‎09-03-2014

Re: Canon Rebel locks up,

naw, I just tried the alternate lense.   :  (    same results.....

Highlighted
Respected Contributor
Posts: 1,861
Registered: ‎12-02-2012

Re: Canon Rebel locks up,

The T3 does have video. The button on back of camera that has a picture symbol of the back of the camera LCD on it is for video and live view. Next to red dot. Hit the button once then see if it shoots stills again. If not press again and try again. I think the button toggles from live view to video to stills again. I have a T3i which is a little different but once I accidentally bumbled into live view or movie mode or something and it took me a while to figure out what I'd done.

Read your manual about video and live view and it will explain better.
Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?
Occasional Contributor
Posts: 8
Registered: ‎09-03-2014

Re: Canon Rebel locks up,

[ Edited ]

Scotty, I think your on to something. I checked the back of my camera and there is that little picture symbol of the back of the camera LCD. So apparently this camera does have a video mode. This camera really belongs to my girlfriend; I asked her if it had a video mode and she said no. But then again I'm the one trying to troubleshoot the problem for her and be a forum slug. So I guess the moral is, don't ask your girlfriend about her own camera? lol. no ok, seriously. I really do think your onto something because, remember I said that the camera turns on and all the buttons and menus work? Like I can check the photos on the SD card and I can scroll through them and I can change shooting modes etc. The only problem being that when I press to the button to take a photo the camera locks up. Well, now that isn't entirely true now. When I press that little button with the picture symbol on the back of the camera with the LCD on it, THE CAMERA LOCKS UP! So, essentially both of those buttons, the video button and I guess the 'picture-taking' button, (I gotta figure out the name of that button) both lock the camera. Then I gotta do a battery pull and the camera comes back from the dead. So weird. So maybe we're moving in the right direction with the video mode. Also, I noticed this as well. When I click the shutter button (that's whay I'll call it for now) to take a photo the camera locks up, and when I pull open the battery door the camera beeps to I guess warn me that I'm about to pull the battery. But when I click that video button and the camera locks up, when I open the battery door the camera does not beep. I'm just trying to provide everything I've noticed involving this weird weird situation. wow, ok, I'm literally playing with this camera while I'm typing this. I just noticed something else. Scotty, I really think you've found a common thread. Ok, when I do a battery pull and the camera comes back on. If I turn the top dial all the way around to video mode, the camera locks up again. So those seems to be the three things that locks this camera. The shutter button, picture taking button. And, the video mode, whether I use the top spin dial or press the video mode button on the back. Both of those methods lock the camera. So I really think this DOES have to do with the video mode..... This is progress. So I'm excited about that. Also I noticed when I lock the camera using any of the two video mode methods I previously described. If I wait about maybe 80 seconds or so, I hear the shutter click once. But that's it the camera still isn't responsive, and I need to do a battery pull. I know we didn't solve this problem yet, but I want to say thanks again for getting us closer to the problem and thus perhaps to a solution. 

Occasional Contributor
Posts: 8
Registered: ‎09-03-2014

Re: Canon Rebel locks up,

I noticed something new. Remember me saying that if I wait about 80 seconds I hear the shutter click? The click is the shutter opening back up again. When I enter video mode or click to take a still picture, when the camera locks up, the shutter closes and stays closed. That click after 80 seconds or so is the shutter opening back up. But the camera is still unresponsive even afterwards. A battery pull is still necessary. I was just curious what was going on with the click after a while. The more and more I work on this thread the more I figure out about this problem. I had no idea it was a video mode problem, but that seems to be a lead. I just thought I'd replay and let you guys know I figured out what that click after 80 seconds was. 

Respected Contributor
Posts: 1,861
Registered: ‎12-02-2012

Re: Canon Rebel locks up,

The button on the back next to the red dot does two different things.
If you have your top mode dial on video, then that back button starts and stops the video.
If you have the camera in another mode, then that back button puts the camera in "live view" which flips the mirror up so the camera no longer focuses normally through the mirror inside, but instead tries to focus on the sensor, and so you can't see through the viewfinder eyepiece because the mirror is flipped up for live view. That is what you are perceiving as the shutter opening up.
The 80 seconds could be the camera taking a video, or maybe it is waiting for you to take a video and then giving up when you don't.
When you say you are manually focusing, are you clicking the MF/AF switch on the lens, or are you turning the mode dial to Manual (which is something entirely different).
Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?
Respected Contributor
Posts: 1,861
Registered: ‎12-02-2012

Re: Canon Rebel locks up,

Go into MENU. Toggle through the pages/tabs until you find one that says something to the effect of "reset all settings" or restore to default or something. I don't have a camera here. . Do that reset.

Put the camera in green box mode and take a picture. Also try one in P mode and one in Tv mode. Anything?
Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement