Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎01-29-2013

Canon Rebel T3I - I am seeing a "squiggly" line - almost like a hair or pigtail - in my viewfinder.

I am seeing a "squiggly" line - almost like a hair or pigtail - in my viewfinder.  I've powered on/off several times but the line is still there.  Any suggestions?

Esteemed Contributor
Posts: 2,342
Registered: ‎11-14-2012

Re: Canon Rebel T3I - I am seeing a "squiggly" line - almost like a hair or pigtail - in m

Get used to it. It's probably a piece of lint or thread or even hair, but it won't effect your photos. It's relatively common for things like that plus dust to get into there. Unless you can easily remove the focussing screen don't mess with it.

"A skill is developed through constant practice with a passion to improve, not bought."
Highlighted
Respected Contributor
Posts: 1,005
Registered: ‎10-23-2012

Re: Canon Rebel T3I - I am seeing a "squiggly" line - almost like a hair or pigtail - in m

Jgowan,

 

What you are seeing is probably some sort of debris in the viewfinder.  You can try blowing air into the side of the viewfinder or up into the viewfinder through the front of the camera using a bulb syringe type of blower.  If it is still there in the viewfinder after that, it can be removed by our Factory Service Center.

 

To start your repair process, you'll need to complete a Repair Request on our website.

 

If this is a time sensitive-matter, additional support options are available at Contact Us.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement