Canon Community Canon Community
 


Reply
Esteemed Contributor
Posts: 3,524
Registered: ‎02-17-2016

Re: Canon EOS 100D Not turning on with an sd in

Look in the card slot and see if there is anything that might be preventing the card from connecting. If there is, you can try blowing it out.

Honored Contributor
Posts: 6,006
Registered: ‎11-13-2012

Re: Canon EOS 100D Not turning on with an sd in

There is also a switch in the camera that senses thew card. If that is malfunctioning the camera won't know a card is installed. But it should give you a "No card" message on the LCD.

 

Give Canon a call at 1-800-OK-CANON.

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Occasional Contributor
Posts: 12
Registered: ‎02-02-2017

Re: Canon EOS 100D Not turning on with an sd in


@kvbarkley wrote:

Look in the card slot and see if there is anything that might be preventing the card from connecting. If there is, you can try blowing it out.


Slot is clean

Occasional Contributor
Posts: 12
Registered: ‎02-02-2017

Re: Canon EOS 100D Not turning on with an sd in


@jrhoffman75 wrote:

There is also a switch in the camera that senses thew card. If that is malfunctioning the camera won't know a card is installed. But it should give you a "No card" message on the LCD.

 

Give Canon a call at 1-800-OK-CANON.


It knows that the card is installed,it says it needs formatting,but when i format it tells me to get an other card

 

Honored Contributor
Posts: 6,006
Registered: ‎11-13-2012

Re: Canon EOS 100D Not turning on with an sd in

Does Thant happen with more than one card?

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Occasional Contributor
Posts: 12
Registered: ‎02-02-2017

Re: Canon EOS 100D Not turning on with an sd in

[ Edited ]

@jrhoffman75 wrote:

Does Thant happen with more than one card?



Yep

Honored Contributor
Posts: 6,006
Registered: ‎11-13-2012

Re: Canon EOS 100D Not turning on with an sd in

Need to contact Canon. 

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Occasional Contributor
Posts: 12
Registered: ‎02-02-2017

Re: Canon EOS 100D Not turning on with an sd in


@jrhoffman75 wrote:

Need to contact Canon. 


Just as an idea,what may have gone wrong with the camera?

 

Honored Contributor
Posts: 6,006
Registered: ‎11-13-2012

Re: Canon EOS 100D Not turning on with an sd in

You could try this if you are comfortable with a little precision work. The stuck switch is sometimes a cause of not detecting a card.

 

Capture.JPG

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Esteemed Contributor
Posts: 3,524
Registered: ‎02-17-2016

Re: Canon EOS 100D Not turning on with an sd in


@L3apr wrote:

 


Just as an idea,what may have gone wrong with the camera?

 


It is broken. Sorry to be snarky, but there is really no way to tell.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement