Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎05-13-2018

Canon 800D (T7i) - slower writing and blinking red light

I have a lot of experience with Canon Rebel series, so you may exclude the very basic solutions ;-) I have taken about 480,000 images with Canons 400D, 450D, 550D, 600D, 700D.

 

I have a new 800D. 2 months old. I'm using it with fully charged original battery and another fully charged off-brand battery. I used it with 6 thoroughly tested 8GB-128GB full sized memory cards, among them Sandisk Ultra 80MB/s, 40MB/s, Adata and Goodram (very decent Polish brand). All of these are fast and allowed writing full HD clips without interruptions.

 

I never had this problem with previous cameras. What problem?

When the memory card becomes filled, there are moments, when the busy red light keeps on blinking and blinking long time after taking a photo. Normally it would take a second, suddenly it blinks for 1 or 2 minutes. When it keeps blinking, the shutter button takes a long time to respond, sometimes I click and it doesn't take the picture. Important: all the time, the viewfinder counter shows that the buffer is empty and ready and that I can take 9 RAW images. Well, I cannot. I can take a photo every 2 seconds instead of 4-5 photos a second. When I turn off the camera, the light stops blinking. When I turn it back on, sometimes it keeps on blinking, sometimes not. Mind you, no data is lost. I take a few photos and it blinks endlessly and slows down. I turn it off. I take out the card. All images are right there, nothing is lost, so I can't explain what it keeps on doing.

After I change the card, it's OK for some time. One time, after card change, the camera wouldn't low level format a perfectly good card. I turned it off for a few minutes. Turned it on again. Now it formatted the card just fine.

 

Important: I had some experience with really slow SD cards. It's nothing like that. With slow memory card, the viewfinder buffer counter decreases after each shot and it stops taking pictures when it reaches 0 (buffer full, now have to wait until image is saved to card). Then it gradually increases to 1, 2 etc... In my case the buffer is empty and I should be able to take at least 9 RAWs in quick succession, which I'm able to do unless the camera starts its blinking shenanigans.

 

The issue occurs at unpredictable moments, but usually when memory card is at least half filled. Sometimes it's at 70GB point in 128GB Sandisk Ultra. Sometimes it's at 7GB point in 8GB card. Sometimes it's at 49GB of 64GB card.

 

Only reasonably possible explanations I can provide are:

  • Failing in-camera card writer
  • Failing buffer memory

What are your thoughts?

Esteemed Contributor
Posts: 2,497
Registered: ‎02-17-2016

Re: Canon 800D (T7i) - slower writing and blinking red light

Take all the images off and reformat the card in the camera.

Honored Contributor
Posts: 6,538
Registered: ‎08-13-2015

Re: Canon 800D (T7i) - slower writing and blinking red light

I think you are making one or more false assumptions.  I question your card selection.  You may also have a camera settings issue.  Are you shooting RAW, JPEG, or both?

 

Your Sandisk Ultra is almost ideal for your Camera, but I question its’ performance at 128 GB.  I would use 32 GB, or less, with that particular card.  I use the 64 GB Sandisk Extreme in my cameras,  not Extreme Pro, which is UHS-3.  I am going to ignore your other two cards, because i do not know anything about them.

You make no mention of what type of shooting you are doing.  The most common cause of extended periods of “buSY” is due to extended continuous shooting.  You mention that you have seen the buffer count drop to zero.  That’s pretty good.  I have never seen that before.  I stop before it bottoms out.

In continuous shooting mode, the CPU is doing a lot of work, so turn off and disable all of the “noise reduction” and  “correction” settings, especially if you are shooting JPEGs.  Create folders, and try not to exceed 999 photos in any one folder.  

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
New Contributor
Posts: 2
Registered: ‎05-13-2018

Re: Canon 800D (T7i) - slower writing and blinking red light

I reformatted the cards in the camera, it didn't help. I reformatted a few cards with low level format and a few with regular format. There is no difference in performance.

I mostly do city/street/editorial photos. I rarely need to use really fast burst modes. Sometimes in low lighting conditions (longer exposure, like 1/15s) I take 3 RAWs in burst mode to select one that is not shaky.

I'm shooting maybe 50/50 RAW+JPEG or JPEG.

I've seen buffer count drop to zero while fast shooting RAWs on my old backup 4GB cards (Class 4).

The problem is that I enconter the blinking/slowness issue not during continuous work, but in random moments. I mean, I'm walking the city, I haven't taken any image in last 3 minutes. I take one image of something, I rotate the camera to take a vertical one, which probably takes one second and I learn by clicking the shutter that nothing happens, camera is doing its busy thing.

What makes me most suspicious is that in Canon 700D I was able to fill all the cards flawlessly. Images from Canon 800D are only 33% bigger, that can't be the explanation. ESPECIALLY, I'll underline that again when the buffer allows 9 RAW images. When buffer has space for 9 images, it doesn't matter whether or not I use noise reduction and or aberration correction, because esentially it takes RAW images, stores them in buffer and does the CPU magic in background.
Honored Contributor
Posts: 6,538
Registered: ‎08-13-2015

Re: Canon 800D (T7i) - slower writing and blinking red light


@tupungato wrote:
I reformatted the cards in the camera, it didn't help. I reformatted a few cards with low level format and a few with regular format. There is no difference in performance.
.

Your replies are pretty much meaningless.  I have no idea what you are doing, and cannot reproduce your issue.  You are making false assumptions about what should be good.  

 

Comparing the performance of the two cameras with different buffer sizes is misleading.  The camera with the larger buffer will need more “buffer space” on the card to write data.  The fact that you do not have issues until your cards are nearly full is telling.

Like I said, your 128 GB card is suspect.  It is too big for a UHS-1 card, IMHO.  You have confirmed my suspicions that you are shooting JPEGs.  I suggested disabling any and all noise reduction and image correction settings in the camera, including lens correction and peripheral illumination.  

Better yet, shoot just RAW, and see if the problem goes away.  Do not be surprised it if does.  

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement