Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎04-14-2019

Canon 700D/t5i LCD displays 'black' not 'blank'

So my t5i doesnt display my menus/reviews and such. I dont not have a rubber eyecup and it that sensor is clean, thats out of the way. When i turn the camera on, it displays black, not that it doesnt work, but the screen turns on and gets power and displays a black screen. I have been able to get to my menu, but i have to press my menu button and spam it atleast 20x before i am successfully able to see into my menus. I have gone throught the info screen and am able to set the lcd screen on and off. it doesnt change anything. I dont know if something is loose in wiring? though that doesnt make sense since i can open menus when i spam the button. any help is appreciated. I have turn it on and off, updated firmware when i am able and tried different sd cards. not looking forward to a expensive repair.

Honored Contributor
Posts: 7,772
Registered: ‎08-13-2015

Re: Canon 700D/t5i LCD displays 'black' not 'blank'

Buy a replacement for the missing eyecup.
----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement