Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎08-10-2019

Cannon Rebel T6i / 750D autofocus not working

I have a cannon 750D that is not autofocusing correctly. I've checked that it is the camera and not the lenses as I've tried it on 3 different lenses. Do I need to send the camera in for repairs or is there some easy fix (drivers maybe) that should resolve the problem?

 

Highlighted
Honored Contributor
Posts: 6,150
Registered: ‎11-13-2012

Re: Cannon Rebel T6i / 750D autofocus not working

[ Edited ]

Exactly what is happening?

 

Go into the Menu screen and clear all camera settings and clear all custom settings.

 

Switch to Green Square A+ and then see if problem still exists.

 

Annotation 2019-08-10 081424.jpg

 

 

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LR Classic
New Contributor
Posts: 2
Registered: ‎08-10-2019

Re: Cannon Rebel T6i / 750D autofocus not working

[ Edited ]

One day later and the camera seems to be having the same problem, it can focus from about 1.5m 0.312m but it doesn't want to focus above 1.5m. It just seems to stop as if it has reached infinity. I've done the reset of all settings and custom.

Is there anything else I could do or should I just send it in for repairs?

Honored Contributor
Posts: 6,150
Registered: ‎11-13-2012

Re: Cannon Rebel T6i / 750D autofocus not working

Before you send it in for repair:

 

1. is there a camera store or a camera club nearby you where you could have a scond person look at it?

 

2. give Canon a call at 1-800-OK-CANON..

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LR Classic
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement