Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎10-28-2017

Can I put Rebel t5i firmware on my t6i so that I can get Magic Lantern on it? Is this plausible?

Title says it all. 

 

I want Magic Lantern on my t6i for obvious reasons, but there isn't a build for the t6i. Can I take firmware from the t5i and put it on my t6i, then install Magic Lantern on that?

Highlighted
VIP
Posts: 10,584
Registered: ‎08-13-2015

Re: Can I put Rebel t5i firmware on my t6i so that I can get Magic Lantern on it? Is this plausible?


@_Curtis wrote:

Title says it all. 

 

I want Magic Lantern on my t6i for obvious reasons, but there isn't a build for the t6i. Can I take firmware from the t5i and put it on my t6i, then install Magic Lantern on that?


D0n’t even think about it.  If you try it, I can guarantee you that your camera will magically turn into a brick.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Highlighted
Frequent Contributor
Posts: 107
Registered: ‎07-23-2017

Re: Can I put Rebel t5i firmware on my t6i so that I can get Magic Lantern on it? Is this plausible?

[ Edited ]

I'm not sure, maybe someone knows better than I, however, my first guess is NO, you can't. 

 

The T6i uses a different sensor and processor than the T5i. The DIGAC processor is geared for the 24MP vs the 18 MP on the T5i. I doubt the older firmware would work with the newer camera.

Highlighted
Honored Contributor
Posts: 5,558
Registered: ‎06-25-2014

Re: Can I put Rebel t5i firmware on my t6i so that I can get Magic Lantern on it? Is this plausible?


@_Curtis wrote:

Title says it all. 

 

I want Magic Lantern on my t6i for obvious reasons, but there isn't a build for the t6i. Can I take firmware from the t5i and put it on my t6i, then install Magic Lantern on that?


No, there's virtually no chance that the T5i firmware would work on a T6i. But so what? Magic Lantern supersedes the camera's firmware anyway, so it probably doesn't matter what firmware that is. But for the same reason that Canon's firmware for the T5i won't work on a T6i, neither is a version of ML designed for the T5i likely to work on a T6i.

 

Food for thought: The reasons for using ML may be obvious to you, but there are a fair number of us who consider trying to use ML to be a silly waste of time and effort. We may be totally wrong. But then again, we may not be.

Bob
Philadelphia, Pennsylvania USA
Highlighted
New Contributor
Posts: 1
Registered: ‎10-29-2017

Re: Can I put Rebel t5i firmware on my t6i so that I can get Magic Lantern on it? Is this plausible?

[ Edited ]

"Magic Lantern supersedes the camera's firmware anyway, so it probably doesn't matter what firmware that is."

 

This assumption is not correct. Magic Lantern doesn't replace Canon firmware. It's working quite similiar to your browser running on your computer: An additional program. In other ways ML is more restricted. Most computer programs are able to work on different operating systems versions (Windows 8, Windows 10, ...). ML is programmed to run on a dedicated firmware version for each cam type.

 

But essentially you are right: There is no way to run T5i firmware (Digic 5 processor) on T6i (Digic 6 processor). And - at time of writing - there is no ML for Digic 6 cams.

 

And questions about ML might be answered in ML forum (they know ML, after all) after browsing through search. It's not the first time this kind of question came up.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement